LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-18-2014, 01:42 AM   #1
zinny
Member
 
Registered: Aug 2013
Posts: 35
Blog Entries: 1

Rep: Reputation: Disabled
Repo help


Pls can someone help me resolve this issue i encountered today.

A kvm that i have installed on a redhat 6.3 machine could not resolve a host server on another machine for its repository. i edited the .repo file, enabled it and turned the gpgcheck off. i also edited the /etc/yum directory where i have the rhnplugin.conf under pluginsconf, changing the enabled from 0 to 1. the kvm could ping the machine in which is hosted on and the machine can ping it back however the kvm cant ping the server on another machine where the repo file is mounted and they are all in the same domain.
if you think is from the network settings, could you pls show me or type the correct way for me to edit the network files cos i gave my network setting a static ip and made all other changes i though could get it to work.

secondly, when i use the fdisk or cfdisk command to partition the virtual disk, it shows no free space on the virtual hard disk while there is still space on it.

could you please assist me in resolving the issues.

Error messages
1. could not resolve the host server.
2. no free space available.
Thank you.
 
Old 02-19-2014, 03:00 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,245

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
few things

you do have the required redhat support contract ?

that should have flipped the "rhnplugin" from off "0" to on "1"

see the redhat docs
https://access.redhat.com/site/docum...erprise_Linux/

second PLEASE!!!!!! spell out your words
Please is NOT SPELLED AS "pls" !!!!!


third
Quote:
turned the gpgcheck off
never turn that off
you NEED to be able to check if all the bits in the rpm ARE REALLY present
and none of them were dropped

so keep that turned on

Quote:
secondly, when i use the fdisk or cfdisk command to partition the virtual disk, it shows no free space on the virtual hard disk while there is still space on it.
that is the way it works
nothing wrong there
a gemu-kvm ( redhat )
vm's are just a img file
it is ALWAYS 100% full even if only 5% is used

and see :"Virtualization_Administration_Guide"
https://access.redhat.com/site/docum...ide/index.html
 
Old 02-19-2014, 03:47 PM   #3
zinny
Member
 
Registered: Aug 2013
Posts: 35
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thank you for your response and correcting me in all the areas you pointed out, however are you saying the disk works normal by not allowing me to make partitions on it saying there is no free space available.
 
Old 02-19-2014, 05:08 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,245

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
that is how a VM image works
fdisk will never tell you the .img partitions
it is just seen as a file
and it will always be 100% full

Last edited by John VV; 02-19-2014 at 05:10 PM.
 
1 members found this post helpful.
Old 02-20-2014, 11:54 AM   #5
zinny
Member
 
Registered: Aug 2013
Posts: 35
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thank you once again. Now that I want to create partitions on it to be able to convert it to lvm, how do I go about doing that. What other command can I use to be able to achieve that.
 
Old 02-25-2014, 06:31 PM   #6
zinny
Member
 
Registered: Aug 2013
Posts: 35
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Please where can I make this thread as solved. Thank you
 
Old 02-25-2014, 06:34 PM   #7
zinny
Member
 
Registered: Aug 2013
Posts: 35
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Using cfdisk solved the issue for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 19 Repo seems to be pointed to the dropbox repo only hawksin Linux - Software 3 07-26-2013 10:50 AM
[SOLVED] Trying to split a large SVN repo into one git repo. Ian John Locke II Linux - Software 1 01-30-2012 09:19 AM
Best way to automate copying of Git repo to subversion repo? jceipek Linux - Server 0 03-15-2011 03:42 AM
how to use syanptic in fc 5 and how to add repo and which repo to be added.. vikas04522 Fedora 1 08-26-2006 01:41 PM
adding mirror to yum.repo.d/<any-repo> ashwin_cse Fedora 1 03-10-2005 04:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration