LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-10-2015, 10:01 AM   #1
ss32
Member
 
Registered: Apr 2013
Distribution: Ubuntu, Linux Mint, RHEL, CentOS
Posts: 43

Rep: Reputation: Disabled
Removing Quota Check at login?


I have an NFS mount and I get an error for every user at login
Code:
quota: error while getting quota from DISK:/volume1/backup for USER (id 123456): Connection refused
I have run
Code:
quotaoff -a
with no luck and added the "noquota" flag to /etc/fstab for that disk but neither have done anything. I restarted the NFS service and re-mounted the disk as well. What am I missing?
 
Old 11-10-2015, 05:32 PM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.10, Centos 7.5
Posts: 17,700

Rep: Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494
Just to check, have you been editing/mounting on the client side or the server side or both?
Also, 'connection refused' sounds deeper than just a quota issue.
 
Old 11-17-2015, 09:33 AM   #3
ss32
Member
 
Registered: Apr 2013
Distribution: Ubuntu, Linux Mint, RHEL, CentOS
Posts: 43

Original Poster
Rep: Reputation: Disabled
The client side. The server side is an NAS box. The connection is refused likely due to privilege issues, only root is allowed to access that disk.

Last edited by ss32; 11-17-2015 at 10:12 AM.
 
Old 12-04-2015, 11:24 AM   #4
ss32
Member
 
Registered: Apr 2013
Distribution: Ubuntu, Linux Mint, RHEL, CentOS
Posts: 43

Original Poster
Rep: Reputation: Disabled
Some more info on this:

When I log in as root the error isn't there, so it's a permissions error of some sort. I tried changing the disk and its directories to 0444 but still got the same error. Is there a way to set mount/connections privileges?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH Login - Bypass public Key check (temp disable passwordless login) Lunar Linux - Networking 1 02-23-2014 05:25 AM
Check if quota is enabled in Linux bostjan Linux - General 6 09-18-2010 07:23 AM
[SOLVED] How to check whether quota is on/off on a particular mountpoint rhadmn Linux - Enterprise 2 08-08-2010 10:34 AM
how to check print quota frcrce08 Linux - General 1 01-04-2009 11:18 AM
removing libstdc (to check RPM dependencies) anadem Linux - Software 6 11-25-2008 07:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration