-   Linux - Newbie (
-   -   removing packages..??? (

mhd_Ahmed 06-27-2003 02:18 PM

removing packages..???
every time am trying to run the wine application this message appears:
" the package "wine" is currently installed "
and when i tried to uninstall or delete this package using this command:
" rpm -e wine-20030508-1rh9winehq "
this error appears:
" error reading information on service wine: No such file or directory
error: %preun(wine-20030508-1rh9winehq) scriptlet failed, exit status 1 "
plzz tell me how can i remove this package from my system....

david_ross 06-27-2003 02:24 PM

To find the exact name of the installed package try:
rpm -qa | grep wine

This should give you the file to uninstall (don't include "-version"):
rpm -e wine-blah

mhd_Ahmed 06-28-2003 04:27 PM

i tried it but still can't to remove or uninstall the package, plzz try to find another way....

sbb 08-22-2003 10:53 AM

I get

[sbb@localhost sbb]$ rpm -e winex-3-1
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm

david_ross 08-22-2003 12:46 PM

You will need to be logged in as root.

All times are GMT -5. The time now is 02:13 PM.