LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Removing Old Version of Glib (https://www.linuxquestions.org/questions/linux-newbie-8/removing-old-version-of-glib-63746/)

Subleak 06-04-2003 11:25 PM

Removing Old Version of Glib
 
I'm currently trying to install GAim.
After Upgrading my versions of glib and pkg-config to meet the reqs of GAim, im receiving an error with i attempt to ./configure GAim folder.

*** 'pkg-config --modversion glib-2.0' returned 2.2.1, but GLIB (2.0.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old verions of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH environment variable, or by editing
*** /etc/ld.so.conf . Make sure you have run ldconfig if that is
*** required on your system.
...

how would i go about doing one of those 2 things?
1) remove the old version of GLib
2) modifying LD_LIBRARY_PATH

which would be easiest?

Thanks for any Help

Running Debian 3.0R1 Kernel 2.4.18-bf2.4

gusto 08-10-2003 04:31 AM

I ran into the same problem.
I did just:

rm /usr/lib/libglib*

and then I run

/sbin/ldconfig

and everything works fine.

I don't know if this is the right solution. But it worked for me.


All times are GMT -5. The time now is 05:14 PM.