-   Linux - Newbie (
-   -   Remounting raid (sda1) drive on reboot (

spammy163 04-28-2006 08:38 PM

Remounting raid (sda1) drive on reboot
Hello...I am pretty new to Linux and desperately need some help.

I am running Debian Linux 3.1 (2.6.8) and just added a 3ware 9500S-LP4 RAID card. I also have four WD 250gb RE SATA drives. I have all four drives plugged into the RAID controller in which I have the hardware array set up. I am booting from hda which is separate from my RAID drive array.

Linux recognizes my 3ware card and boots fine.
I fdisk'd the raid drives using fdisk /dev/sda1.
I set up the partition and did mkfs.ext3.
Everything went fine....then I mounted it using 'mount /dev/sda1 /music'
the drive was then accessible and works great.

However, upon rebooting the system, I have to manually mount the sda1 drive to access it. I modified the fstab file and I still have to manually mount it each time after reboot. Can somebody please help me? What am I doing wrong or not doing? Any help would be greatly appreciated.

Thank you in advance.

David the H. 04-29-2006 01:11 PM

You'll have to show us what entry you're using in fstab, and more details about how you're mounting it and any error messages and such you're getting.

You haven't by chance given it the "noauto" option, have you?

spammy163 04-29-2006 02:58 PM

Here is my fstab file. I think that it may be trying to mount the /dev/sda device before it loads the raid controller drivers. I could be wrong...I am a newbie! Thanks for the reply.

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/sda /music ext3 defaults 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

All times are GMT -5. The time now is 12:11 AM.