LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   reinstalling lilo in gentoo? (https://www.linuxquestions.org/questions/linux-newbie-8/reinstalling-lilo-in-gentoo-146519/)

bigjohn 02-15-2004 08:33 PM

reinstalling lilo in gentoo?
 
I've managed to kill my gentoo install by trying to put mandrake 10 beta 2 on the other partition.

I don't suppose anyone could explain how I'd go about reinstalling the lilo so I can boot the gentoo?

the gentoo is on /dev/hda5 and the boot partition is on /dev/hda2 if that matters at all?

regards

John

p.s. I've tried to have a go at re-installing using the liveCD, and I've read load's of doc's, but i'm totally lost, and in rather over my head

DrOzz 02-15-2004 08:36 PM

pop in a rescue disk, and run :
lilo

bigjohn 02-15-2004 08:39 PM

I tried that, and didn't get anything.

erm, I then tried to "emerge" lilo, and it just says command not found.

I'm presuming that when I fire up the cd, I'm still working from the drive, and not actually in the /dev/hda5 install. Hence no emerge facility.

regards

John

DrOzz 02-15-2004 08:43 PM

i have never used gentoo, but i assume the below instructions that i will link would be the same ..
click here

are you saying you did that ?
and when you say, you tried that, and didn't get anything, what do you mean exactly ?

Demonbane 02-16-2004 04:35 AM

Tried booting your Gentoo using the Mandrake bootloader(whether its grub or lilo)?

Stanley56 02-16-2004 01:32 PM

Just insert the gentoo cd, boot to your root and then configure the /boot again like in the installation instructions.
When configuring grub.conf, just add the Mandrake option.

Gentoo = control ;)

bigjohn 02-16-2004 04:49 PM

Well, I tried DrOzz's link suggestion. ZIP. I just get told no such image found, for either linux rescue or just rescue.

demonbanes idea won't work. The mandrake version of lilo will start the windows XP, but not mandrake (the current install effort is 10 beta 2, which won't boot).

So I found some stuff as to what I might be doing wrong, but to no avail.

I did mount -t proc none /mnt/gentoo/proc and then did the chroot stuff, as part of the error from yesterday said something about /proc/partitions so I wondered if that had anything to do with the problem.

I wasn't sure what else I should do from there, so I did /sbin/lilo which gave me this:

Warning: '/proc/partitions' does not match '/dev' directory structure
Name change: '/dev/ide/host0/bus0/target0/lun0/disc -> '/dev/hda'
The kernel was compiled with DEVFS_FSm but the 'devfs=mount' was omitted as a kernel command-line boot parameter; Hence, the '/dev' directory structure does not reflect DEV_FS device names.
Fatal: open /boot/kernel-2.4.20-gentoor6: No such file or directory


So I did emerge lilo and after a while it just stopped "doing it's thing" and said emerge lilo failed and then said the same stuff as above.

I even tried doing this, as I managed to look into /boot yesterday, but don't know how I did it, and I don't know if there was a copy of the kernel info there, cp /usr/src/linux/arch/i386/boot/bzImage /boot/bzImage but I still seem to be getting nothing.

Can you see what I'm doing wrong ? or what I should try next ?

many thanks

John

crashmeister 02-16-2004 05:01 PM

Well - if I remember right you first slap in the gentoo CD and then mount the partitions.
mount /dev/hda5 /mnt/gentoo
mount /dev/hda2 /mnt/gentoo/boot
after that a 'chroot /mnt/gentoo /bin/bash' and running lilo should be good enough.Of course that will only boot gentoo afterwards - you'll have to configure lilo to boot mdk if you want to.Damn mdk did the same to me once.Specified not to install a bootloader and it slapped one on anyway.

bigjohn 02-17-2004 02:30 AM

Thing is crashmeister, the mandrake won't boot anyway. Something's gone wrong with the install of the mandrake 10 beta 2 - it just hangs half way through the boot, and I don't know how cure that one!

regards

John

crashmeister 02-17-2004 05:22 AM

Last one I did was mdk 9 and I am not planning on any further installs ;-)
Can you get at least the gentoo part going?

bigjohn 02-18-2004 02:51 PM

Cos we haven't got a gentoo distro forum, I found their's.

After various suggestions, I've ended up doing a re-install, just to save my sanity. That, in itself, isnt' too much of a problem.

The difficulty is, that after downloading up to date versions of the 2 disc liveCD set, got as many instructions as I can find and "gone for it", I've ended up with a full install, but without any window managers yet.

When I got to the reboot stage, to get pre compiled binary packages from the 2nd disc, it went and told me that there was no mount point for /dev/cdrom /mnt/cdrom and wouldn't let me do much from there.

Don't get me wrong, I feel that "portage" is vastly superior to any version of rpm and apt-get. But it's a bit of a pig, to have to download and compile - kde, last time I had to do it, was 175 megs, and it took 15 hours to download and compile each "sub package" one at a time.

And the install worked brilliantly.

But this time, it obviously didn't get everything installed, or I missed something in the install guide, cos I've just spent about 2 hours downloading/compiling/installing XFree 4.3 and now all I've got to do is to work out how I get kde (the portage tree is now at kde3.2 so that should be excellent - when I finally manage to sort it !!!)

Oh, and I doubt whether I'll bother with mandrake until version 10 final is available.

regards

John

crashmeister 02-18-2004 07:46 PM

Try 'emerge -s kde' - if it isn't there you don't got it.
As for the cd:You should have something like this in fstab:

/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro,user 0 0

and you'll need /mnt/cdrom as a mount point of course.
If you want to compile it yourself you might want to check what you really want because 'emerge kde' installs everything kde.Try to install kdebase first and then just get anything else you might want - who needs noatun and all that crap anyway?

You can also try to search the gentoo forums for something like 'kde compile time'. There are some tricks to have it compiled faster.


All times are GMT -5. The time now is 07:43 AM.