-   Linux - Newbie (
-   -   Regenerating Old PCs.. (

EchoNation 01-03-2012 08:01 PM

Regenerating Old PCs..
I have a few PC around, and I figured I'd give them one last chance to be useful. I've used Linux before.. about 15 years ago. That being said, I have two Deskpro's I'd like to use as file servers. Problem is I've downloaded at least 5 different Linux Distro's. The Only one that really has done anything is a Linux boot/Tools Disc I found. I have a 39G Drive, Ram is low, but I don't need speed I need a place to store Mp3's of Promo's, Liner's and that we use for the radio network. With 22 Stations, I can't be up 24/7 sending these files to them, or have a place to upload them. I just can't get anything to work. Any Idea's on what I'm doing wrong?? Thanks Echo

frankbell 01-03-2012 08:35 PM

What are the specs of the computers, especially CPU type, clock speed, and RAM?

My first guess is that the RAM is too low or the chips are too primitive (in computer terms, that is). If it's under 256 MB, you will likely have trouble finding a contemporary Linux distro that will do a full GUI install.

If the machines are 15 years old, that would put them in the mid-90s. If they are first generation Pentiums, you might be able to get a really light-weight distro like Puppy or possibly the Salix minimal install to work.

A 39 GB hard drive has plenty of HDD space to load a working distro. A full Slackware install, for example, takes up about eight gigs.

EchoNation 01-03-2012 09:09 PM

Well One is a Compaq Deskpro 2000 and the other a 4000. Run Windows 95/98 without and problems. I've downloaded all the Linux OS's I thought would work. Latest download was DSL 3.4.11, I have Puppy Too... But for some reason, they are not loading to the point I can do anything with them. The HD is partitioned for Linux, I did that by using Linux Boot/Tools.. And it boots from the CD, everything else I've tried has failed :( I mean hell I got Win3.11 to load on a 286 back in 1992. And that wasn't easy or was even fast.. Boot and go make a pot of coffee before the Logo Screen loaded...

jefro 01-03-2012 09:39 PM

There are a lot of issues with older drives. They don't like cd-r media and worse is cd-rw. They don't like low or medium quality cd-r media they seem to run on good quality disks. They also don't like being burned at anything other than the very slowest speeds. That all all assumes they even boot to a cd.

If you can't get puppy or dsl then you may need to go even smaller.

EchoNation 01-03-2012 09:50 PM

Well if I can't get them to work by Friday... I'll be scraping the whole lot..Not into things that, have no direction. Linux is one of those things... All over the web you can read about how someone else has gotten it to work.. But they don't say how..??? Infact no one does... LIVE CD?? I mean I have 3 of them.. they don't work either.. and I don't have a PC with a Floppy drive in it.. If I didn't want it to load, it would.. And even the old stuff DSL doesn't load.. Oh I bet I know why... it's not a LIVE ISO... so it won't. But I'll keep jacking with it, and when I Figure it out, I will Post the Right way to do it.

EchoNation 01-04-2012 07:59 AM

Good Morning... Ready to start my day.. I figured someone here.. would have had the answer :( The only thing I can think of, that I'm doing wrong is that my system is not setup correctly? With Linux Boot/Tools that works I was able to Partition the drive to be all Linux. Maybe there is where I went wrong, I don't know, Hence the reason I'm here.

rodrifra 01-04-2012 08:07 AM

Try DSL (Damn Small Linux). It's only 50Mb and will run on 128Mb machines.

Sorry, I dind't see you tried it before.

You appeared to have failed in your intention to install it because you did a frugal install. To install it to HD you will have to "Install to HD" instead of frugal install.

Start from CD, after that create a partition (at least 200MB) and mark it as bootable.

Use fdisk to partition and mark your partition as bootable (d to delete partitions, n to create new partitions and a to mark as bootable, m for help). Use mkfs.ext2 for instance to create your fs.

Once you have done that, mount your new partition in /mnt/your-device (there will be a directory for the new partition you have created)

And finally, you can now press right button on your desktop, go to apps->install to HD and you will have your system with DSL installed.

Captain Obvious 01-04-2012 08:07 AM

I'm confused... What exactly IS your problem? lol. Can you even boot into linux? Or does it just not install?

What happens when you try to boot from one of the live CD's (or USB's)?

DavidMcCann 01-04-2012 10:53 AM

You still haven't told us how much RAM you have, or, for that matter, the exact problems you have.

AntiX will run (with limited web browsing facilities) in 64MB with a 486
Vector Light is happy in 128MB with a Pentium I
WattOS needs a minimum of 192MB but will work with a 386 (If you have less than 256MB, install from the boot options, not from the live session)

These are stable, easy to use, and come on CD rather than DVD.

EchoNation 01-04-2012 10:58 AM

The Deskpro 2000 has 64MB of RAM the Deskpro 4000 has 198 MB of RAM Currently the biggest HD I have is a 39G. Other HD's I have are 2 and 4Gig drives. I also have a 250 and 340 Gig Drives but I know these drive will not work on these old systems...

EchoNation 01-04-2012 11:05 AM


Originally Posted by EchoNation (Post 4565928)
The Deskpro 2000 has 64MB of RAM the Deskpro 4000 has 198 MB of RAM Currently the biggest HD I have is a 39G. Other HD's I have are 2 and 4Gig drives. I also have a 250 and 340 Gig Drives but I know these drive will not work on these old systems...

My biggest issue is What you do, and how do you do it, to make the systems See the CD roms, cause with out the systems seeing those, how will it boot from a USB?? I mean seriously? USB was like the "NEW" thing for these computers back in the day, right up there with network cards... of which the DP4000 has one built into the mother board, the DP2000 has a Kingston Card. I just want a starting point. To Work from... I've heard so much about what Linux can do, and what Windows has Failed on... Now I hear about "The Cloud" what the heck...It's like saying "The Hovercar is coming"...

JimBrewster 01-04-2012 11:45 AM

If you want to get around cdrom issues, you can try installing grub2 (that easiest from a minimal CD like supergrub2disc), and copy iso files to your hard disk. You can then boot directly from the images on hd using grub2's loopback feature. Distros to try include SliTaz, Salix LXDE or fluxbox edition, or Porteus (LXDE boot option).

colorpurple21859 01-04-2012 03:42 PM

With that amount of ram most modern distos will not work with a gui even some of the so called light distros. I think puppy 4.3 will work if you do a full hard drive install. the frugal install eats up more memory. The puppy 4.3 versions with the older kernel version will most likely give better results. The newest puppy version though considered light will have trouble on that amount of memory. A bare install of debian may work, maybe try Slackware 10.2, it is still available on most slackware mirrors. siltaz is another one to try. Dsl linux is now dead and no more supported.

EchoNation 01-04-2012 03:59 PM

Ok... I'm looking for something will will setup my system to put in any linux on my HD. Cause I have PCMagic, and it let me work with my HD, but after that.. No other options. I've downloaded all the linux iso's that "say" they can run on old machines. But so far I can't get them to install on a HD, therefore I'm stuck. I don't know enough about linux to get around on it... at least with DOS, I can.. even some of the old commands. I last used linux, to learn a little about loading and running programs on a SUN machine, and a Full blown Unix machine... that was over 17 years ago... If i knew how to get around on linux, trust me I wouldn't be here, asking dumb questions... I know, I am windows corrupted file, I should have deleted myself or upgraded a long time ago...

ivandrago 01-04-2012 04:34 PM

Try openfiler or freenas.

All times are GMT -5. The time now is 03:40 PM.