-   Linux - Newbie (
-   -   RedHat9.0 Critical updates changing lilo.conf (

daleswankz 08-19-2003 09:42 PM

RedHat9.0 Critical updates changing lilo.conf

today i ran some updates for my redhat9 distribution..i suppose the kernel was updated because when i reboot the machine and look at the bootloader, instead of there only being two nice things to choose from (linux/dos) there are now linux.bak, linux, a string of numbers, and dos. ive edited lilo.conf in the /etc dir but to no avail. this has happened each time i've done updates (i've had to install redhat9 perhaps 5 times so far) and i don't know how to remove those extraneous choices from my LILO bootloader.

can anyone help?


DrOzz 08-19-2003 10:10 PM

well the extra choices are appearing because you are selecting the kernel update, and you are on the right track by editing the /etc/lilo.conf file, but you have to make the changes finalized by running /sbin/lilo when your done.

daleswankz 08-19-2003 10:13 PM

oh, ha ha ha -- that would make much more sense..i couldn't figure out why the lilo.conf file changes wouldn't appear..

thanks a bunch, i'll try that now!!

daleswankz 08-19-2003 10:48 PM

just to let you know, it worked fine. thank you again for the help. however, i think i may have caused myself an even bigger problem..i will post the question here, and start a new thread because i am desperate. i tried to change my user name in the redhat user manager, i waited and waited and finally decided to cancel the process -- i refreshed the dialogue box, my name appeared as changed, i thought it ok to reboot -- tried to logon, the new name doesn't exist and the old one doesn't work either. anyway to fix this, or am i to reinstall redhat for the 6th time because of my own idiocy?

All times are GMT -5. The time now is 03:54 PM.