-   Linux - Newbie (
-   -   redhat won't boot to gui (

mgendron57 09-14-2004 03:01 PM

redhat won't boot to gui
My install of redhat 7.3 (need that version for testing) will not boot to any gui. Only command line. I've tried to upgrade per a suggestion but it never asks me for a gui type to choose from?



masand 09-14-2004 03:11 PM


did u go with installing X server paclages and any desktops like kde and gnome

if not then u should upgrade or reinstall,installing them individually will be a headache


zLinuxz 09-14-2004 03:20 PM

when you are in command prompt....and you type #]: startx
or #]:initx
are you able to get into Xwindow?

if you are able to enter the gui interface by typing startx from the prompt, then everything is okay....and all you need to do is type 'Linux 5' at the Boot loader prompt, then you will be able to automagically enter gui during bootup.

mgendron57 09-14-2004 03:25 PM

complete install
I did a complete install including everything! I just don't understand why it won't come in kde or gnome...Just the command line???

zLinuxz 09-14-2004 03:32 PM

what boot loader are you using?

did you try the Linux 5 option at bootup?
that means that you want Linux to boot in Level 5, which means GUI interface.....

chrism01 09-15-2004 09:06 AM

If you definitely want a GUI, then edit the file
and change this line:
change the 3 to a 5 and it will always bring up a GUI if it can ie assuming you installed one.
rpm -qa |grep -i gnome
rpm -qa |grep -i kde
to see if you have installed either.

mgendron57 09-15-2004 10:58 AM

thanks it worked
Thanks Guys. I just re-installed and was able to get the gui of my desire. I did go in and edit that file before that and it did work but needed a different OS anyway.


All times are GMT -5. The time now is 04:40 PM.