LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Redhat linux9.0:System hangs,if gives init 3 or init 4 (https://www.linuxquestions.org/questions/linux-newbie-8/redhat-linux9-0-system-hangs-if-gives-init-3-or-init-4-a-231184/)

Sailaja Reddy 09-16-2004 12:39 AM

Redhat linux9.0:System hangs,if gives init 3 or init 4
 
Hi All,

I have redhat linux 9.0 with compiled kernel 2.6.7 (default was 2.4.20-8).
Currently it is running in runlevel 5. Output of "runlevel" command is "n 5".

System is hanging, when I try to run in level 3 (init 3) or level 4(init 4). Unable to get control, some number is printing continuously in the terminal.

Why my system is hanging?
Am I missing some thing?

I am completely strucked up and any info on this would be GREATLY APPRECIATED..

Output of my /etc/inittab:
#
# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf:owerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345owerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:2345:respawn:/etc/X11/prefdm -nodaemon


Thanks & Regards,

subhasis_ray 09-16-2004 12:46 AM

Hi Sailaja,

Have you tried doing the same thing with the default kernel? Try that and see if u get the same problem.
Looks like an issue with the 2.6 kernel, although I am not sure.

Cheers

Subhasis

Sailaja Reddy 09-16-2004 01:44 AM

Hi Subhasis,

Thanks for the reply.

Yes, I even tried with redhat linux 9.0 with default (inbuilt) kernel: 2.4.20-8.
The same problem is coming.

I am just wondering, whether I missed out some options at the time of installation?

Regards,
Sailaja

Sailaja Reddy 09-16-2004 03:24 AM

Update..........

In both the cases, with default kernel and upgraded kernel. The following thing works:
- In level 5
- init 3
- System kind of hangs (mouse works properly, not able to get the control of keyboard). Some number is printing continuosly in the terminal
- Ctl + ALt + F1 (going to text mode)
- Ctl + Alt + F7 (back to GUI)
- Control comes back and it is actually in level 3 and everything starts working.

It solved the problem of changing runlevels.

Is there any patch to avoid doing Ctl + ALt + F1 and Ctl + Alt + F7?
Having xdm. Is this the problem with GUI?

Thanks,

subhasis_ray 09-16-2004 04:19 AM

looks like something to do with the keyboard driver..... not sure. I have a optical mouse(samsung) and in CUI the thing never works..... does something similar to what u r reporting. is your keyboard a normal ps2 one or something different?

-Subhasis


All times are GMT -5. The time now is 09:29 PM.