-   Linux - Newbie (
-   -   redhat enterprise linux (

vinu1974 08-10-2004 03:29 PM

redhat enterprise linux
iam new to linux , could anybody tell me what the difference between redhat enterprise linux AS, and fedora , which is better ? what should i install? if i install fedora does it contains everything which is in redhat enterprise linux?


masand 08-10-2004 03:41 PM

RHEL is not free version
it is paid version meant for corporate usage

u need to use other available f downloadregards

btmiller 08-10-2004 03:43 PM

Fedora is a "technology preview" -- i.e. the software is being tested for possible eventual inclusion into RHEL (Red Hat Enterprise Linux - AS, ES, etc. are subproducts of RHEL). It's less stable in general and is designed for the hobbyist/enthusiast market. It's also a free download. RHEL is really for companies who need big, expensive support contracts and assurance that software won't be obsoleted in a short time. RHEL with support costs $$$ and is really designed for the corporate user. There's no difference in the software you can install on each (unless RH threw a couple proprietary goodies into EL). If you're starting out, and you have to go RH, I'd go with Fedora Core 2 at the moment. If you want to see what RHEL is like, a distro called White Box is a clone of RHEL without the support (and hence without the large cash pay-outs).

vinu1974 08-11-2004 11:40 PM

redhat AS,ES,WS

Thanks for the valuable information , i tried to install fedora core 2 but due to some cd errors i was unable to do so, so hope next time i will suceed , i don't like windows, as i had seen linux on my friends computer its really great and works great , lots of application,

does fedora2 have support for all hardwares? i mean i have P4 HT 2.6 ghz processor 256, ram 64mb nivida gforce agp, intel 865gbf mb, lan card 10/100mbps, c-media sound card.



rm6990 08-12-2004 05:35 AM

I don't have all that on my computer but more or less have all the parts spread around on many computers...all running Fedora Core 2. They all worked great with no searching for drivers or nothing. Oh, and you might want to try SuSE Personal or Mandrake or Debian (Network install of testing, don't use Woody, very outdated) too, but for now u could prolly stick to fedora. Make sure u check the md5sums, go to and go to the downloading xandros tutorial and they have a link to a good program for windows that can check the md5sums of the iso images....match them up with the md5s at, ttyl

vinu1974 08-12-2004 10:19 AM


rm6990 , thaks for your valuable suggestion,
i had installed fedora and choosed workstation and downloaded some rpms from xmms , but from root or user i cant open that rpms even it doesn't displays the error, and the i think there is some problems with the permissions,

the permission are like this

-rw_ _ _ r_ _ _ _ _

i don't know how to change the permissions so that i could install the packages, pl: help in thois regard



rm6990 08-12-2004 11:13 AM

Now, I haven't worked wth RPM's all that much cause I left yum and apt do all the work for me. I'm not sure, I don't think they need to be flagged as executable, but just in case at the terminal:

chmod +x filename.rpm

and then to install at the terminal go

rpm -ivh filename.rpm

yum, which comes installed with fedora, is a good utility that handles a lot of that stuff for u. Log in as root and type in

yum search (insert a word from what you are looking for) and it will search all the packages for a match. Say you are looking for an mp3 plugin for xmms and it comes up that the name of the package is xmms-mp3 (I believe that is the name of it) you would type at the prompt

yum install xmms-mp3

yum will automatically download and install. You can even do this for huge programs like open office or games...oh and for everything i have told u make sure u r root or none of it will work is an awesome site that will help u out with using fedora....there is a yum.conf file u can download from it into ur home directory...then open a terminal window and su to login as root then type

mv yum.conf /etc/yum.conf

this will replace the file that tells yum where to download files from with a better file, the new file will still include Red Hat's servers, but also other servers and will make updating a lot faster. Oh, and one more tip....

yum update

will update every package on ur system, even ones up2date won't spot updates for. Anyways, yum makes things a lot easier because with RPM's, if you are missing a dependancy, you have to go on the net and track it down, whereas with yum it downloads/updates all of the dependancies for you. Anyways, thats all. Ttyl.

tuxrules 08-12-2004 11:17 AM

well if it doesnt display any error, then you might have installed it. what did you exactly do? "double-click" on the rpm name in the GUI. If you did that as root then it got installed but if you did that as a regular user it should ask you for root password.

whats the name of the rpm you are trying to install?

try this
# su -
enter your password

# cd /path/of/your/rpm
# rpm -Uvh name.of.your.rpm

vinu1974 08-13-2004 01:47 AM


ya tuxrules you are correct i double click on the rpm in GUI but i did it as root , the rpm are of flash and xmms, and when i give LS command from the terminal tty1 then these packages are in RED color, so i hope thats some thing is wrong with permissions, so i think i have to try as rm6990 said to change the mode. but normally i had seen several guys download the rpm and just in a double click it is installed , and why is it wrong with me? is it due to some improper installation? or some packages are missing ?



tuxrules 08-13-2004 10:25 AM

RH 9 uses color coding to give visual info about file types

blue for directories
red for RPM's
green for executables

as I indicated in my earlier posts, you can install rpm by those commands.
-U option upgrades the earlier install
if you are sure you dont have that package use


rpm -ivh packagename.rpm

# man rpm
To answer you question about double-click, I personally prefer to install everything using command line (double-click is for windows). If you install using command line, it will give you info if it requires any more packages (dependencies). If it needs dependencies, you can go to and search for packages.

I would suggest you get apt-get or yum for easier package managment.

tuxrules 08-13-2004 11:02 AM

i would suggest you use rpm command to query if you've already installed the package.


#rpm -qa | grep part-of-the-package-name
refer man pages for more info

masand 08-13-2004 12:09 PM

if u have downloaded the correct rpms then
they are executable by default
i think u haven't downloaded the correct rpm's from XMMS

try installing different rpms from the fedora CD


vinu1974 08-13-2004 01:13 PM


ya , regarding you are right iwas trying to install xmms rom wich was for fedora1, i installed it from fedora 2 cd its sucessfullay installed :)

As iam experiencing LINUX is really sea of adventures where you explore new things everyday,, one question regarding x window as i said regading doubleclicking any rpm it shows this message:

There is no action associated with "xmms-mikmod-1.2.10-1.i386.rpm".
You can configure GNOME to associate applications with file types. Do you want to associate an application with this file type now

not espicially for this almost for every packages!

there's one new problem arised today i.e. now my system work very slow , is it due to any process in background? how should i check it even if i give the command to halt or powerdown it take almost 2-5 min .

thanks to all of you for your kind support which helped me a lot
my be thats the power of linux!!



masand 08-13-2004 01:38 PM

hi vinu

to use rpms it is best to use the bash prompt

#rpm -ivh abc.rpm

to se that if ur system is slow
go to system settings-->server settings-->services

close the services which are of no use
for example u do not rewuire nfs,smb(if u r using a single machine,not in a network) rhnsd,apmd etc etc

also the one good option is to compile ur kernel

i am usnig my own compiled kernel and getting excellent performance


vinu1974 08-13-2004 03:27 PM

Hi ,

ya after stopping several services as you said now it quite working well , is there any email client from i can get my external mails like hotmail? as in windows outlook do.



All times are GMT -5. The time now is 04:05 PM.