LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-22-2003, 05:38 PM   #16
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15

I ran the command and two errors came up.

Quote:
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.20-9'
make: *** [vmlinux] Error 2
 
Old 04-22-2003, 05:54 PM   #17
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
once the patches are installed you do not need to install them to that source again, just running make mrproper or distclean will only clean up the files created by the make process.



I guess the error could be due to having a problem with the modutils

In the "loadable module support" section disable "Set version information on all module symbols"

see if that fixes that error.


However if everythings been installed it's more than likely something in the config

Last edited by DavidPhillips; 04-22-2003 at 05:56 PM.
 
Old 04-22-2003, 06:09 PM   #18
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15
I disabled it but new errors came up.

Quote:
make[3]: *** No rule to make target `/usr/src/linux-2.4.20-9/drivers/pci/devlist.h', needed by `names.o'. Stop.
make[3]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/pci'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/pci'
make[1]: *** [_subdir_pci] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-9/drivers'
make: *** [_dir_drivers] Error 2
I'll check the config again.

Should I enable Kernel debugging in Kernel hacking?

Last edited by digsy; 04-22-2003 at 06:11 PM.
 
Old 04-22-2003, 06:32 PM   #19
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
turn off "PCI device name database" in the General section


don't use the kernel debugging
 
Old 04-22-2003, 06:50 PM   #20
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15
I got the same errors when I tried it the first time.
I think I left out some of the error messages first time, sorry about that.

Quote:
drivers/char/char.o(.text+0x1d37a): In function `omnibook_proc_ac':
: undefined reference to `omnibook_proc_len'
drivers/char/char.o(.text+0x1dabb): In function `omnibook_proc_battery':
: undefined reference to `omnibook_proc_len'
drivers/char/char.o(.text+0x1dee6): In function `omnibook_console_blank_status':
: undefined reference to `omnibook_proc_len'
drivers/char/char.o(.text+0x1e13a): In function `omnibook_proc_display':
: undefined reference to `omnibook_proc_len'
drivers/char/char.o(.text+0x1e28a): In function `omnibook_dock_status':
: undefined reference to `omnibook_proc_len'
drivers/char/char.o(.text+0x1ecc9): more undefined references to `omnibook_proc_
len' follow
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.20-9'
make: *** [vmlinux] Error 2
 
Old 04-22-2003, 07:56 PM   #21
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
the killsyms was a kernel patch


make sure the omnibook is a module, there is a problem when setting it to *
 
Old 04-22-2003, 08:14 PM   #22
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15
To make the Omnibook a module, I have to set [M] for HP (and other) laptop support in the config, right?
 
Old 04-22-2003, 08:17 PM   #23
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
right, that's the only way I could get it to work with the ACPI enabled
 
Old 04-22-2003, 08:18 PM   #24
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15
New errors came up..

Quote:
make[3]: *** No rule to make target `/usr/src/linux-2.4.20-9/drivers/pci/devlist.h', needed by `names.o'. Stop.
make[3]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/pci'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/pci'
make[1]: *** [_subdir_pci] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-9/drivers'
make: *** [_dir_drivers] Error 2
My PCI Support was enabled.
PCI Access Mode = Any
PCI device name database = disabled

Last edited by digsy; 04-22-2003 at 08:20 PM.
 
Old 04-22-2003, 09:15 PM   #25
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
wow, that one again

did you run make mrproper
 
Old 04-22-2003, 09:57 PM   #26
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Yes, I think the first thing I did was to run make mrproper.
But I couldn't use kpatch so I used make, make install to install the Omnibook file.

Is there any way to check if I ran make mrproper, or can I still run it?
 
Old 04-23-2003, 02:19 AM   #27
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
yea you can try it again

but remember that each time you recompile the kernel and run modules_install if you did not use kpatch, you will need to rebuild and install the omnibook module.

also you will need to load it in your startup scripts or load it manually after boot with this

modprobe omnibook
 
Old 04-23-2003, 05:50 PM   #28
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Hooray!
I could finally build the kernel!
(What I did was since ./kpatch didn't work, I did "make kpatch")


But the custom kernel doesn't boot.
Here's the error I get

Quote:
NET4: Unix domain sockets 1.0/SMP for Linux NET 4.0
VFS: Cannot open root device "LABEL=/" or 00.00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 00:00
Do I have to configure my boot loader (GRUB)?

Last edited by digsy; 04-23-2003 at 05:51 PM.
 
Old 04-23-2003, 06:48 PM   #29
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
you should add the new image to your grub.conf

I would also consider using this instead of LABEL=/

root=/dev/hda?

whatever the device is
 
Old 04-23-2003, 10:20 PM   #30
digsy
LQ Newbie
 
Registered: Mar 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Sorry, I tried several times, but I always get Kernel panic.
Could you tell me where I should edit?
Here's my grub.conf

Quote:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/hda5
# initrd /initrd-version.img
#boot=/dev/hda
default=3
timeout=20
splashimage=(hd0,1)/grub/splash.xpm.gz

title Red Hat Linux (2.4.20-9custom)
root (hd0,1)
kernel /vmlinuz-2.4.20-9custom ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-9custom.img
title Red Hat Linux (2.4.20-9)
root (hd0,1)
kernel /vmlinuz-2.4.20-9 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-9.img
title Red Hat Linux (2.4.20-8)
root (hd0,1)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-8.img
title DOS
rootnoverify (hd0,0)
chainloader +1
hda1: Windows 2000 NTFS
hda2: Boot EXT3
hda3: Linux-swap
hda4: Extended
hda5: EXT3 (Linux main)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get ACPI working on Toshiba L10 Laptop???? mickyg Linux - Laptop and Netbook 3 09-15-2005 03:44 AM
Sound and ACPI issues on a Toshiba A60 Satellite laptop Fenster Fedora 9 10-18-2004 08:25 PM
ACPI problems with Toshiba Laptop Running Suse 9.1 lhawk Linux - Newbie 0 08-12-2004 02:51 PM
Toshiba Laptop with 11b network and redhat 9 dude_228 Linux - Networking 7 10-04-2003 05:47 PM
RedHat 9.0 Toshiba laptop reboot freeze sardaukar_siet Linux - Software 0 04-16-2003 02:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration