LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   RedHat 9 and Nvidia (https://www.linuxquestions.org/questions/linux-newbie-8/redhat-9-and-nvidia-71894/)

Baklan 07-11-2003 12:47 PM

RedHat 9 and Nvidia
 
I'm trying to install ia32 Nvidia drivers v1.0-4363 on RH9 (Kernel 2.4.20-8). I have Geforce3 TI500.

I install the drivers:

sh NVIDIA-Linux-x86-1.0-4363.run

I edit my XF86Config file:

Change driver "nv" to driver "nvidia"
Make sure i have Load "glx"
and remove Load "dri" and Load "GLcore" if they are present.

I startx, the screen goes black then returns with the message:
"(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

and in about 5 secs the comp freezes.

What can be wrong here? On nvidia site it says that these drivers support RH9. I just installed it and i can't understand why these drivers wont work.
I have read the nvidia README file but it doesn't help much in this case. I did check that i have ld and my kernel is supposed to be supported by this version of drivers. What else can be wrong?

I tried to uninstall them and install them again but still no luck. Please help.

ingy866 07-11-2003 05:19 PM

Right... a quick tip, as I'm sure I encountered something similar with Debian 3. Try going to /lib/modules/(kernel version)/kernel/drivers/video and (if it's there) doing insmod nvidia.o . Try running startx again. Dunno about the freezing though.

Baklan 07-11-2003 08:55 PM

I did what you said and it told me to check in BIOS if i had:
P & P OS OFF (which i had off)
Assign IRQ to VGA ON (which was off as well)

I turned it on and now it works perfectly. THANK YOU! :)

ingy866 07-12-2003 02:22 PM

Good to hear. :)

It annoyed me for ages in Debian, that was when you had to compile the drivers from source, it was just one error after another. Glad to be of help though! :D

DKnight 08-13-2003 12:08 PM

I recently had the same problem with the same solution with one caveat: my bios did not have an option to assign an irq to the video card ... so I turned plug and play OS off in the bios and then noticed that there was an option to reset the flash memory the bios was using this option was in a completely different menu on the bios btw ... setting that to yes and plug and play os to no gave the desired result upon reboot. My board is an INTEL i810 (bought it for stability, so far no regrets through rh7.2, then 8 and now 9).


All times are GMT -5. The time now is 04:38 PM.