LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   redhat 8 and linksys router, dsl (https://www.linuxquestions.org/questions/linux-newbie-8/redhat-8-and-linksys-router-dsl-73081/)

richardg 07-15-2003 08:59 PM

redhat 8 and linksys router, dsl
 
OK, chimps on a keyboard would be doing better than me. I have 2 computers and a linksys router (BEFSR41, I think, the one with the firewall and the VPN). Earthlink DSL is working fine and I share the connection thru the router; everything works fine with Win98SE. Pretty standard stuff, I think.
Redhat 8 is up and running as a dual boot on one of the computers. I can do what I need to do ( C++ and perl), but I would like to connect to the internet thru the linksys router. I have seen this thread several times, but it always seems to end "tweak a few settings, simple as pie".
So, on to the question: what precise actions are needed?
I can ping the router just fine, and the connection is stable. The browser will bring up the linksys screen just fine. However, when I point the browser to, say, redhat, it reports the site is not available. I can ping the other computer on the network just fine.
ifconfig reports the connection is up, and it seems fine. I have tried 'route add default gw 192.168.1.1 eth0' which would seem to be the right command, and then route -n gives 192.168.1.1 as the default gw. /etc/resolv.conf is empty, but how do I fill it in? domain, search and nameserver fields are needed, I guess, but how do I find out what they are ( earthlink seems to have lots of entry points, which makes sense).
The more I read about iptables, dns and dhcp the more I want to know, but it is about time for a little positive feedback (like getting to the internet with RH8)
Thanks!

Capt_Caveman 07-15-2003 10:17 PM

The easiest way to do this is to setup dhcp.

OK. Start with the Linksys router. Go to the web interface and click on the DHCP tab, make sure that "Enable DHCP server" is selected. Save your changes. Now click on the Status Tab. In the WAN subsection, make sure that you have a public ipaddress assigned and that there are ip addresses for the DNS servers of your ISP.

So far, so good.

Now fire up X and run neat (start-button -> System Settings -> Network). It will prompt for the root password. You should see you interfaces listed. Click on your external interface (eth0 more than likely) so that it's highlighted. Now click edit. Under the General settings you need to click the radio button that says "Automatically obtain IP address settings with" and make sure that the drop down window says "dhcp". Also make sure that "activate device when computer starts" is selected. Click OK. Now click the "Apply" button.

Restart mozilla and try to navigate to a URL. You might have to reboot, but I doubt it.

HTH

richardg 07-16-2003 03:31 PM

OK, so I whip over to the linksys router, and DHCP server is already enabled. In the WAN subsection, there are public IP addresses and DNS servers already (makes sense). Fire up the network and eth0 is indeed the interface, and the radio buttons that says "automatically obtain IP address setting with" already says DHCP. The "activate device when computer starts" and "allow any user" buttons are checked.
It would seem no changes are needed, yet the browser connects just fine. Go figure. I have been fooling with this for a week, off and on, perhaps I just needed that one more reboot...
I will continue reading and learning, and I'm sure I will be back.
FWIW (literally) I made a contribution to this board. Capt_Caveman, think about an affero nickname. thanks again

Capt_Caveman 07-16-2003 03:52 PM

Glad you got it to work! Remember when all else fails, reboot and if that doesn't work a swift kick helps sometimes. This is a great forum to learn linux, so come back and post again. Thanks for the kind words, just happy I could help.


All times are GMT -5. The time now is 01:29 PM.