-   Linux - Newbie (
-   -   RedHat 8.0: Sis900 Configuration (

The Wall 12-31-2002 03:34 PM

RedHat 8.0: Sis900 Configuration
I'm not able to get my integrated Sis900 PCI LAN chip to work on RedHat 8.0.

I'm totally new to linux world and would appreciate it if someone spoon-fed me on how to get this thing working.

I'm running AMD Athlon 1700+ with 256 MB DDR RAM,
Integrated SiS 900 LAN (cant get this to work)
Integrated Sis 7016 Audio (cant get this to work)
Microsoft Intellimouse Optical USB (cant get this to work)

Thanks for the help.

The Wall 01-06-2003 07:13 PM

tried a lotta things but nothing seems to work...even tried a kernel recompile but still SiS900 doesnt work out :(

Anyone know more??

ry 01-07-2003 12:45 PM

for your network card, try to login as root and issue the command:


Look for the module sis900, if you cant find the module on the out put of that command, you may install it by:

modprobe sis900

Then reconfigure the network by:


And then restart it by:

service network restart

pjrobin 01-07-2003 06:11 PM


I have the same problem.

What I did :

- added kernel parameter "pci=bios" (found that it may help)
- command lspci - v -v -> the SiS900 is recodnized
- modprobe sis900 -> error
- dmesg -> "v1.08.04 4/25/2002 ... eth0 : Error EERPOM read fff"

I've then checked on a forum and found this thread :

The version of SiS900 in RedHat 8.0 seems to be too old ! I hae no idea, how we can update this module...


Boss Hoss 09-20-2003 04:36 PM

I'll pull this thread back up since it seems relevant to my problem..

I'm installing RH7.3 to be able to use Ensim's WebAppliance Pro for Linux and I'm finding one problem. I'm installing Rh7.3 Kernel2.4.18-3 on i686 from tutorial I have and I'm finding I have a problem connecting to eth0 (Error EERPOM read ffff) using the sis900.c v1.08.03 module. I don't see support while googling for my chipset SiS962L(SiS651) until kernel 2.5.13 patch?

So where I can I get either the highest releast kernel of RH7.3 with/or a sis900 module that supports SiS962 chipset?

Boss Hoss 09-21-2003 12:53 PM

ok, try a simpler question:

given sis900.c & sis900.h files that supposedly work for the sis962 chipset, how can I make just this one module sis900.o needed for current kernel compilation?
and you'd think we'd name it sis962.o by now?

Do I understand it correctly that the sis900 module is backported from 2.5.x into 2.4.22 for the sis962 chipset problem? So if I install the 2.4.22 kernel it should work?

All times are GMT -5. The time now is 08:53 AM.