Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-30-2002, 04:23 PM   #1
Registered: May 2002
Location: Mexico
Distribution: Slackware
Posts: 118

Rep: Reputation: 15
RedHat 7.1 can't connect to internet

AGAIN another distribution that does not work on my computer.

i run KDE not Gnome. the only way to configure the net is to click on the big K then go to system then network. in that configuration thing there are 4 tabs: Names, Hosts, Interfaces, Routing.

under names i didn't add anything because there is nothing i could add in there, my ISP has no hostname or nameserver (the things you can add in)

under Hosts i didn't add anything becuase i don't want to get into that whole manualy specify my IP crap.

under Interfaces i added a new thing, it automaticaly named it eth0 but it has no assigned IP, no assigned netmask, network is, broadcast is, i selected for it to activate on boot up and to configure through DHCP (i have dynamic IP)
i restarted the computer and it hung on detecting eth0 for about 2 minutes then it came out in those big bold red letters FAILED could not detect IP configuration.

well sh!t what the hell do i do now?
Old 05-30-2002, 04:29 PM   #2
Registered: May 2002
Location: Dalec, HU
Distribution: Redhat 7.3
Posts: 696

Rep: Reputation: 30
set it up as dhcp if you have dhcp server on your network, otherwise get proper ip address.
but you need to specify what kind of internet connection are you using? But in most cases you would have dhcp server
Old 05-30-2002, 04:38 PM   #3
Registered: May 2002
Location: Toronto, ON, Canada
Distribution: Ubuntu, Debian, RedHat/CentOS
Posts: 624

Rep: Reputation: 31
If you have a DHCP server, make sure that your /etc/sysconfig/networking/ifcfg-eth0 file has the following contents:
And that your /etc/sysconfig/network file has these contents:
Make sure you set the hostname to something. If you don't have a domain name, you can get a free dynamic IP compatible name from and from (dns2go actually has a Linux client). Linux doesn't work nicely without a valid hostname.

Once you get these set up, log in as root and type "service network restart". That will shut down your network interfaces (your ethernet card "eth0" and the loopback adapter "lo") and bring them up with the new settings. If you really have a DHCP server on your network, you should be up and running in no time.

You can always check your current set up by running /sbin/ifconfig

Good luck!
Old 05-30-2002, 04:53 PM   #4
Registered: May 2002
Location: Mexico
Distribution: Slackware
Posts: 118

Original Poster
Rep: Reputation: 15
a few things
-why would you suggest my ISP doesn't have a DHCP server? all ISPs giving out dynamic IPs NEED to have one or nobody has internet
-how am i supposed to download the client thing if i don't have internet!??!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to the internet Redhat 9.0 stappa Linux - Networking 1 03-09-2005 11:04 PM
Can't connect to internet using RedHat 9. Tennis Holligan Linux - Newbie 2 10-09-2003 11:45 AM
Can't Connect to internet with Redhat 9.0 berryseyx Linux - Networking 2 10-04-2003 02:09 AM
cannot connect to the internet with Redhat 9.0 ndha Linux - Networking 1 06-30-2003 12:02 AM
help me connect redhat to the internet michaelangel Linux - Networking 13 08-10-2002 04:38 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:14 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration