LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Red Hat ver 9 does not shutdown properly (https://www.linuxquestions.org/questions/linux-newbie-8/red-hat-ver-9-does-not-shutdown-properly-75716/)

bclem 07-24-2003 11:39 PM

Red Hat ver 9 does not shutdown properly
 
When I shutdown Red Hat It finishes with the message:
Code: Bad EIP value, with a cursor that is inoperable, and no power-down.
I have tried entering the amp Options to the Linux kernel, but that did not solve the problem of no power-down. Perhaps I did not enter the Options properly, because I am new to Linux!

What does "Code: Bad EIP value mean?

Hope someone can help me solve this.

Regards
bclem:study: :scratch:

ppuru 07-25-2003 01:54 AM

no powerdown - does this mean that the next time you power up, linux goes fsck, complains about not being shutdown properly?

bclem 07-25-2003 05:07 AM

ppuru thank you for your reply .
When I next power up there is no problem. Looks ok to me but its very quick of course.
But when I switch off at the power switch there are three short beeps. Thats all.

Looking_Lost 07-25-2003 06:12 AM

Try turning off apmd to see if it makes a difference

chkconfig apmd off
see if if everything goes smooth next time you reboot and shutdown

for immediate stop

/etc/init.d/apmd stop

LadyMakoChan 07-25-2003 06:18 AM

hmm, i've got the same problem with RedHat 8.0.~ having no idea how to solve the problem~
but by the way... what means "EIP"? Is it a shortcut for something? *n00b*


Mata ne
MakoChan

Looking_Lost 07-25-2003 06:40 AM

It's one of the registers in your CPU methinks - too low level for me though.

plehman 07-25-2003 07:36 AM

I initially thought that maybe this was similar to a problem I was having with my laptop not shutting down. I got no error message, but it hangs after saying "Power Down". My issue is one that apparently affects a number of newer laptops where they don't support APM, instead choosing ACPI which from what I have read seems to be of marginal value if patched into 2.4.x series kernels. You didn't mention what type of computer you were using, so I searched around a little, and here is what I was able to find. Hope this will be of some help.

Some people have been able to fix a similar bug by adding a kernel option to their /boot/grub/grub.conf file. Specifically, they added ' apm=off' at the end of the line that specifies the kernel to load.

Alan Cox (famous kernel guru) noted on one mailing list (lists.insecure.org/lists/linux-kernel/2003/Feb/0226.html) in reply to a question posted by another user that if the CPU is an AMD K6 (predecessor to the Athlon if I'm not mistaken) there might be problems with the way apm shuts stuff down. Here is what he said

"...A lot of old K6 boxes have bioses where the 32bit power down function Linux normally uses is buggy. Building a kernel with the apm real mode power down option might work better..."

This link looked interesting...
http://groups.google.com/groups?hl=e...3D30%26hl%3Den

Also found that EIP stands for Extended Instruction Pointer and is apparently a register containing the memory location that the the CPU is currently executing.

bclem 07-29-2003 05:29 AM

Hi plehman
Many thanks for your help. The URL looks good and I believe we are on the right track.
I am not sure how to configure the kernel though. That is how to get into it.
bclem


All times are GMT -5. The time now is 06:33 PM.