-   Linux - Newbie (
-   -   Red Hat Enterprise Desktop 5.3 on 64 bit machine need 32-bit library file (

hhs1982 06-29-2010 11:41 AM

Red Hat Enterprise Desktop 5.3 on 64 bit machine need 32-bit library file
I have installed Red Hat 5.3 64-bit linux.
I have a program that needs 32-bit and
I have the Red Hat supplemental DVD that has the tcl-devel-8.4.13-3.fc6.i386.rpm and the tk-devel-8.4.13-5.el5_1.1.i386.rpm
I tried to install the tcl-devel-8.4.13-3.fc6.i386.rpm package using the following command: "rpm -ivh --force tcl-devel-8.4.13-3.fc6.i386.rpm

I get the following error message: "Warning: tcl-devel-8.4.13-3.fc6.i386.rpm header V3 DSA signature: NOKEY, key ID 37017186 error: failed dependencies: is needed by tcl-devel-8.4.13-3.fc6.i386.rpm"

I have scoured the internet and everything says to install these packages to get the tcl and tk libraries. What's the deal? Am I just missing something? Any help would be greatly, greatly appreciated!!!

AlucardZero 06-29-2010 12:14 PM

1) rpm --import /etc/pki/rpm-gpg/RPM*
2) install tcl too.

hhs1982 06-29-2010 12:41 PM

ok the imports worked and got rid of the "NOKEY, key ID 37017186" error but I still get the error:

"failed dependencies: is needed by tcl-devel-8.4.13-3.fc6.i386"

How do I get that file?

johnsfine 06-29-2010 12:54 PM

Is this for a registered copy of Red Hat 5.3?

Do you have an internet connection?

If yes to both, why are you messing around with manual install of packages from a DVD? Use the package manager to get what you want and to deal with all the dependencies.

If unregistered with internet connection, why are you messing around with an unregistered copy of RHEL? The software will always be a major pain to install or upgrade. You could use Centos instead of RHEL and then all the package installs and upgrades will be easy.

As for your specific current problem you should have installed
before installing
I think that was the meaning of


Originally Posted by AlucardZero (Post 4018376)
2) install tcl too.

Wim Sturkenboom 06-29-2010 12:55 PM

You don't need the 'devel' packages; you need the 'normal' tcl/tk stuff

All times are GMT -5. The time now is 06:53 PM.