LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-11-2003, 06:47 PM   #1
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Rep: Reputation: 0
Question Red Hat 9 login error and multiple kernals


I have two questions:

1.
I get the following error right before I log in to Red Hat Linux 9:

“Could not look up internet address for x1-6-00-5b-1b-99-60. This will prevent GNOME from operating correctly. It may be possible to correct the problem by adding x1-6-00-5b-1b-99-60 to the file /etc/hosts.”

I think that weird letter/number dash combo was somehow set as my hostname. In the terminal it has a [username@x1-6-00-5b-1b-99-60 username]$ prompt. Can anyone explain to me exactly what this number is, whether it is possible to change it to something more readable, and how I can get rid of the error message? I just set up my red hat linux 9 operating system and installed the workstation type. Everything seems to be working ok even though I keep getting this error.

2.
Also, I updated my kernal using up2date and now Grub lists both the old and new kernal. How can I get rid of the old kernal (I am dual-booting with windows xp so would like to have as much free space as possible)? I searched these boards and think I found a way for Grub to only show the new kernal (alter the /etc/grub.conf file by commenting out the old kernal), but I want to know how to actually delete the old kernal safetly from my hard drive. I have already booted into linux using the new kernal so it seems fine from what I can tell.

Kelly

Windows XP Pro and Red Hat Linux 9 dual boot with Grub
Dell Dimension 8100
40 GB
1.7 GHz
256 MB RAM
32 MB NVIDIA GeForce 2 GTS/GeForce 2 Pro
Turtle Beach Santa Cruz Sound Card
 
Old 08-11-2003, 07:21 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
1) the number is the mac address of your NIC (or possibhly your ADSL modem, if you have one). all you should need to do is set your own hostname to whatever you want using "hostname" command itself. if your ISP insists on doing this, it is perfectly possible to verbosely prevent the DHCP details from being set, in your case, the host name. Looking at the dhcpcd manpage the deafult is NOT to set it though...

2) removing them via a simple "rpm -e kernel-2.4.20" or something should suffice, you'll probably need to (or rather *want* to manually remove the lilo entries though... never nice to have something like that messed around with automatically. if you can't remove it by rpm it will just be a case of removing the appriately named /boot/vmlinuz image and relevant directories in /lib/moduies

2.1) it's kernel not kernal
 
Old 08-11-2003, 11:16 PM   #3
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
hi VKelly,

1) under RED HAT 9.0 (gnome) go to KMENU, SYSTEM SETTINGS, NETWORK, type in your root password and click on OK

then it should bring up the Network Configuration which shows you 4 tabs: DEVICES | HARDWARE | DNS | HOSTS

go to DNS and change the first field (Hostname) to whichever name you want for your system - you should leave the rest as is.

then switch over to the HOSTS tab, and you should see one entry there:
IP NAME ALIASES
127.0.0.1 localhost.localdomain localhost

select this line and click on the EDIT BUTTON

after that just change the Aliases to whatever hostname you have come up with in the DNS tab

example:

under DNS: you chose the Hostname: 'VKelly'
under HOSTS: Aliases: 'Vkelly'

after that just close that window (it should inform you that it has saved the changes and that you should restart the system before it takes effect) - go ahead and do as told: restart and after that GNOME should start up without that prompt anymore.

This was the GUI method I believe

If you are more advanced, just simply change this entire thing in /etc/hosts and you should be all set. hehe...GUI = slow, shell = fast but both can bring the same results


2) do as acid has advised you - perfectly explained!



Hope this helps!

Last edited by slackmagic; 08-11-2003 at 11:18 PM.
 
Old 08-12-2003, 03:47 AM   #4
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Talking Thanks!

Thanks both of you, now I have fixed both of my problems.

1)
At first I tried just using the hostname command and I typed "hostname newname." It seemed to change it as when I typed "hostname" without any arguments, "newname" was displayed. So I logged back in and it took a little extra time when Enabling eth0 (my ethernet card). I also still got the error about the old hostname. So I typed "hostname" and the old name was displayed so it must have gotten changed back to the old name upon reboot. My prompt was still the same as well.

Next, I went to System Settings>Network>DNS Tab and changed the hostname to my newname. Then I went to the HOSTS tab and was surprised to see no entry there. However, I checked what was in /etc/hosts and it had exactly what you wrote above (127.0.0.1 localhost.localdomain localhost).

So I went back to the HOSTS tab and said to add a new entry instead of edit, and put the following in the three boxes (127.0.0.1 localhost.localdomain newname). I pressed ok, and no new entry showed up but it must have altered the aliases part because after I saved my changes and rebooted, everything was displaying my newname instead of the old number, and I also did not get the error message anymore. I also looked at /etc/hosts again and it had my newname as well (127.0.0.1 localhost.localdomain newname). My prompt had also changed as well to reflect the newname.

2)
This worked just fine, first I altered my /etc/grub.conf file and commented out the old kernel. I rebooted and the old kernel no longer showed up in grub.

Next, I became the su and typed "rpm -e kernel-2.4-20-8" and it returned. I looked in /boot and noticed that some of the 2.4-20-8 version files were no longer there.

I will probably go back and delete the comments from the grub.conf file eventually.

Thanks for all your help,
Kelly

Windows XP Pro and Red Hat Linux 9 dual boot with Grub
Dell Dimension 8100
40 GB
1.7 GHz
256 MB RAM
32 MB NVIDIA GeForce 2 GTS/GeForce 2 Pro
Turtle Beach Santa Cruz Sound Card
 
Old 08-12-2003, 07:53 AM   #5
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
1) weird that it didn't show up the entry after you have added it, however I'm glad it's working now

2) yeah you should do that - wonder why you still did rpm -e kernel-2.4-20-8 eventho it already worked after you altered the conf which removed the entry of the other kernel. hehe
 
Old 08-12-2003, 03:01 PM   #6
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by retiredsoldier

2) yeah you should do that - wonder why you still did rpm -e kernel-2.4-20-8 eventho it already worked after you altered the conf which removed the entry of the other kernel. hehe
I think altering grub.conf just removed the entry from grub even though the kernel was still on my hard drive. That is why I did rpm -e to remove the kernel from the hard drive as well.

Kelly
 
Old 08-12-2003, 03:30 PM   #7
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Kelly, you may also want to check you don't have the source still installed for your old kernel, might want to get rid of that too.

use "rpm -qa | grep kernel" to check what kernel packages you have installed. If it is installed uninstall it like you did the last bit.

Don't uninstall anything else though, don't wanna screw everything up
 
Old 08-12-2003, 03:58 PM   #8
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I get

kernel-pcmcia-cs-3.1.31-13
kernel-2.4.20-19.9

I know I want the kernel-2.4.20-19.9 because that is the current one I use but do you know what the other kernel-pcmcia is?

Kelly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat 7.3 and multiple gateways on multiple interfaces bluefmc Linux - Networking 2 11-19-2004 06:01 PM
Multiple Hard Drive Problem with Red Hat 9.0 swap01 Linux - Hardware 1 08-11-2004 06:13 PM
Multiple physical hard drives w/Red Hat 9 masterspud777 Linux - Hardware 7 07-29-2003 05:10 PM
Installing Multiple Versions of Red Hat? tudmuf2b Linux - General 7 03-05-2003 09:13 AM
Multiple Mice in Red Hat? justiceisblind Linux - Hardware 5 01-25-2003 12:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration