LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-07-2014, 05:55 AM   #1
BrutalMusic
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware 14.1 64-bit
Posts: 28

Rep: Reputation: 1
Recompiling MPlayer with xvid support on Slackware


I'm sure the information is out there but I can't figure out where to look...

I have installed xvid but mencoder can't use it. I think what I need to do is recompile MPlayer, but how?

When I run the command:

Code:
mencoder input.mov -ovc xvid -xvidencopts bitrate=1500:pass=1 -vf scale=720:480 -o output.avi
I get the result:

Code:
MEncoder 1.1-4.8.2 (C) 2000-2012 MPlayer Team
-xvidencopts is not an MEncoder option

Exiting... (error parsing command line)
I'm running Slackware 64 14.1. I have installed xvidcore-1.3.2.

I tried uninstalling and reinstalling MPlayer using the package included in the distro, but no difference. I see a slackbuild by alienBob, but it's really old.

I'm guessing I'm supposed to build a new package using an option that asks it to use xvid as a dependency, but how?

Last edited by BrutalMusic; 02-07-2014 at 06:04 AM.
 
Old 02-07-2014, 07:23 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,155
Blog Entries: 3

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
well pretty simple copy
first you will have to install the xvid codec by building it from slackbuilds.

open a terminal put this in it.
Quote:
lftp -c 'open http://carroll.cac.psu.edu/pub/linux....1/source/xap/ ; mirror -c -e MPlayer'
after mplayer is downloaded. inside you will see the slackware build file named MPlayer.SlackBuild open it with kwrite. or any editor you like. and read the patent alert. and then at line number 176
Quote:
USE_PATENTS=${USE_PATENTS:-"NO"}
and change it to
Quote:
USE_PATENTS=${USE_PATENTS:-"YES"}
if you do not understand how to use slackbuilds there is great help doc's there.
 
1 members found this post helpful.
Old 02-07-2014, 07:28 AM   #3
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,571
Blog Entries: 56

Rep: Reputation: Disabled
If you haven't got them, you might need them: mplayer-codecs:
http://slackbuilds.org/repository/14...ayer-codecs64/
 
1 members found this post helpful.
Old 02-07-2014, 07:43 AM   #4
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 327

Rep: Reputation: 73
it's a long time i don't use mplayer to encode, but it isn't "xvidopts"?

ADD : "mencoder -ovc help" shows you all supported video codec

Last edited by gengisdave; 02-07-2014 at 07:46 AM.
 
1 members found this post helpful.
Old 02-07-2014, 08:17 AM   #5
BrutalMusic
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware 14.1 64-bit
Posts: 28

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by gengisdave View Post
it's a long time i don't use mplayer to encode, but it isn't "xvidopts"?
ADD : "mencoder -ovc help" shows you all supported video codec
Nope, it's xvidencopts. Thanks for the command, always nice to be able to get a quick check of what's there. Before I tried the other suggestions, I had the following: copy, frameno, raw, nuv, lavc

Quote:
Originally Posted by brianL View Post
If you haven't got them, you might need them: mplayer-codecs:
http://slackbuilds.org/repository/14...ayer-codecs64/
Thanks, but it didn't fix this issue.

Quote:
Originally Posted by Drakeo View Post
...after mplayer is downloaded. inside you will see the slackware build file named MPlayer.SlackBuild open it with kwrite. or any editor you like. and read the patent alert. and then at line number 176 and change it to...
Drakeo, your answer was exactly what I was looking for. Thanks so much; it worked like a charm!
 
  


Reply

Tags
mencoder, mplayer, recompile, slackware, xvid


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No xvid support in latest mplayer? rpedrica Slackware 10 08-23-2013 07:25 PM
new XviD <=> new MPlayer? six6 Linux - Software 2 09-22-2004 02:15 AM
problem with mplayer+XviD+DivX jogurt666 Linux - Software 2 12-08-2003 03:22 PM
Mplayer, xvid...yaieee shock_ez Linux - Software 13 06-30-2003 12:18 AM
Recompiling RH 7.1 to disable DMA support - chipset doesn't support properly arby73 Linux - Newbie 0 06-13-2001 11:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration