LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Reboot Failure - Upgrade from 8.04 to 10.04 (https://www.linuxquestions.org/questions/linux-newbie-8/reboot-failure-upgrade-from-8-04-to-10-04-a-915563/)

alan fietz 11-25-2011 05:59 PM

Reboot Failure - Upgrade from 8.04 to 10.04
 
Hi, I bought a refurbished computer from FreeGeeks with Ubuntu 8.04 LTS installed. It is about 6 years old now, with an ASUS P4P800SE motherboard (dual Intel P4), 1 GB memory, and an 80 GB Maxtor hard drive (6L080L0).
I upgraded from Ubuntu 8.04 to 10.04 on November 10.
The installation messages were:

Error loading Nautilus config info - Replaced customied /etc/login.defs - Replaced customized /etc/dhcp3/dhclient.conf - 189 packages removed - WARNING: Failed to read mirror file

When I rebooted, the usual ASUS screen appeared, then "Loading GRUB" then "Starting Up..." then "Starting Up..." (again) then a blank screen (the moniter went dormant).

I rebooted, started GRUB and selected: kernel 2.6.32-35 generic. I got the same results.

I rebooted, started GRUB and selected: kernel 2.6.24-29 generic.

Here's what was displayed:

mount.mounting none on /dev failed: No such divice

udevd [874]: error getting socket:
Invalid argument

libudev:udev_monitor_new_from_netlink:
error getting socket: Invalid argument

Segmentation fault
**Gave up waiting for root device**
Common problems
- Boot args (cat/proc/cmdline)
- Check root delay
- check root
- Missing modules (cat/pro/modules;)

**Alert!
/dev/disk/by_uuid/c59c6361 etc...
does not exist.** Dropping to a shell.
Then Busybox v1.13.3 started with the following prompt (?)

(initramfs) _

But the keyboard was locked up.

It appears the hard drive cannot be found. Any suggestion on how to remedy this?

1.If the "root" (hdo,o)" boot command is failing, then can I alter it to have a successful boot?
2.Why did I get the message: "/dev/disk/by_vvid/c59c6361-2363-etc does not exist"? Do I need to respecify the hard drive's ID number somewhere? Where can I find this ID number?
3.Are there GRUB command's I can use to answer and fix the problem?

The Ubuntu forum suggested doing a clean install. I do NOT want to do a clean install of Ubuntu and wipe out my personal data (and all the software and settings I've set up over the past 18 months).

I've tried various boot options:

acpi=off, noapic, nolapic, edd=on,
edd=skipmbr, libata.dma=1

The results were the same, though sometimes slower.

Most recently I tried to run Ubuntu 10.04 directly from a "live" CD. The CD drive was active for 5 or 10 minutes, but nothing happened - the screen was blank, even after pressing keyboard keys, and even after waiting 10 minutes.

I did a memory test (from GRUB) and everything passed.

I'm out of ideas, and my computer has been inoperable for 2 weeks. Help!

Thanks,
Alan Fietz

snowpine 11-25-2011 06:38 PM

Your Live CD test suggests there is a problem running Ubuntu 10.04 on your hardware. I recommend backing up your data/documents and then test-driving a few different Linux distros using Live CDs or USBs.

If you are interested in sticking with Ubuntu then why not try the current 11.10 release instead of the outdated 10.04 (April 2010 release)? I would also recommend trying Mint, Fedora, and anything else on this list that sounds appealing to you: http://distrowatch.com/dwres.php?resource=major

fingers99 11-25-2011 07:13 PM

I've never had much luck installing Ubuntu or running a live Ubuntu CD. It seems to me that it is quite extraordinarily picky about both the device which is being installed to, and the device it is being installed on.

You might like to try Kanotix or Knoppix which are both Debian based live editions, and seem to both have better hardware recognition and be less fussy about the equipment used to install. Of the two, Kanotix is probably the easiest to use as a permanent, multi-user distro and can be (with care) upgraded by traditional Debian methods, or from later CDs.

Both have very friendly forums.

snowpine 11-25-2011 07:29 PM

ps You might find this list helpful: http://www.ubuntu.com/certification/

syg00 11-25-2011 07:36 PM

Presumably you did the LTS to LTS upgrade - otherwise it wouldn't be a supported upgrade.
That said, I've (long ago) found the Ubuntu upgrades to be bloody fiascos. I have a separate /home partition and use two other partitions to flip-flop Ubuntu installs. Works fine - and the user settings are safe. Yes, you may have to re-install products, but ain't anywhere the hassle of broken upgrades ...

Given things like
Quote:

189 packages removed - WARNING: Failed to read mirror file
I'd be worried the upgrade hadn't completed successfully. After which you (we) are going to be groping in the dark.
For the liveCD issue, hit F6 to get the options, hit <Esc> if you need to get rid of the options sub-menu, then edit the boot string to get rid of "quiet splash" then hit <Enter>.
That way you'll get to see the boot messages - and see where/why it stops.

alan fietz 12-01-2011 01:58 PM

Problem Solved
 
Hi,
Thank you all for your input and suggestions. I have solved the problem. An insight came to me while I was meditating: why was I getting:
Quote:

Originally Posted by alan fietz (Post 4534023)
then a blank screen (the monitor went dormant)

So I altered my monitor's setup to use the DVI input line instead of VGA, and guess what? Everything was fine it had been working fine all along, but the monitor wasn't showing it! So the Ubuntu upgrade had executed perfectly. I guess Ubuntu8 supports VGA and Ubuntu10 does not. It took me eighteen days to figure that out. I learned a lot about patience and perseverance (and GRUB). Sometimes (or most times) the journey is more important than the destination. And Ubuntu10 rocks!

alan fietz 12-01-2011 06:02 PM

how do you set up 2 root partitions ?
 
Quote:

Originally Posted by syg00 (Post 4534053)
I have a separate /home partition and use two other partitions to flip-flop Ubuntu installs. Works fine - and the user settings are safe.

I think your method of having 2 Ubuntu partitions is brilliant; how do you configure this? I.e. how do I create 2 root partitions for Ubuntu if they both have the same mount point (i.e. /)?


All times are GMT -5. The time now is 03:13 AM.