LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-06-2017, 05:11 AM   #1
techjaymindave
LQ Newbie
 
Registered: Mar 2017
Posts: 9

Rep: Reputation: Disabled
RANDR extension is too old (must be atleast 1.2)


Its Ubuntu server, with Xrdp installed.

I am not able to attach this server to projector screen.

When I go to System, preference, monitor, it gives this error.

How can I solve this?

Regards,
Jay
 
Old 04-06-2017, 10:58 PM   #2
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,175

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
Which Ubuntu server version? 14.04 LTS reports xrandr version 1.4. 16.04 LTS reports 1.5. What is the output from 'sudo xrandr -v' and 'cat /etc/os-release' in a terminal?
 
Old 04-06-2017, 11:16 PM   #3
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
I don't have server experience but this looks like a start:-

https://ubuntu-mate.community/t/cant...ys-option/8548

https://www.x.org/archive/X11R7.6/do...xrandr.1.xhtml

http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

Since it's complaining that:
Code:
RANDR extension is too old (must be atleast 1.2)
Maybe the version of randr that your running is old?

Ubuntu 16.04 (Xenial) has several pkg's for randr 1.5:-

http://packages.ubuntu.com/search?ke...roto-randr-dev
http://packages.ubuntu.com/search?keywords=randr
http://packages.ubuntu.com/search?keywords=xrandr

HTH
 
  


Reply

Tags
ubuntu 14.04 mate


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Randr extension missing gnew Linux From Scratch 7 01-02-2016 09:03 AM
[SOLVED] 'RANDR extension not present' error message when setting up dual monitors in Ubuntu judoka Linux - Hardware 1 06-21-2014 07:08 PM
Xlib: extension "RANDR" missing on display "MachineName:1.0". Gannoj Sreenivasulu Linux - Newbie 1 01-26-2013 03:36 AM
How to change ownership?(Atleast i think that is problem) centosfan Linux - Newbie 5 04-22-2007 05:07 PM
swap area needs to be atleast 40 kB Sonderblade Linux - Hardware 1 11-18-2003 01:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration