LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   random segmentation faults? (https://www.linuxquestions.org/questions/linux-newbie-8/random-segmentation-faults-281776/)

l00zer 01-24-2005 05:36 PM

random segmentation faults?
 
Im not sure how this is happening, but whenever i try to run something like kde, or firefox, or thunderbird, it just says segmentation fault. No other stuff. I just got it to work yesterday by reinstalling gtk and all that junk. But now its broken!!

i looked at the log by [cntrl] + F9 (10?) and it sayse

kdm : Greeter exited unexpectedly Error 0 Code 11

something like that. It loads the X server and then it dies repeatedly. Any ideas?

I think I first noticed it last night when i was figuring out how to create an rpm out of a simple package. AGH i just fixed it!! Neverending battle!!!

Samsara 01-24-2005 06:29 PM

Do a memtest - your RAM might be faulty:

http://www.memtest86.com/

HTH,

Samsara

l00zer 01-24-2005 08:55 PM

Hmm, the memtest didn't return any errors. If i run xinit or xdm it can log into blackbox. It still cant run kde. I'm thinking I somehow messed up a library somewhere. The repair function doesn't return any errors though. Firfox gives some funny characters then segmentation fault.:confused:

Samsara 01-25-2005 03:51 AM

Reinstall the packages you think are broken, and report back if you still have problems.

Samsara

l00zer 01-25-2005 04:40 PM

thats the problem. I have no idea which packages are broken, and the only errors it generates is segmentation fault. IS there a log file anywhere for the programs? Im finally realizing what i miss about windows. It just works. Its horrible but it works!

edit! got some errors

Code:

run-mozilla.sh line 451: 2549 Segmentation Fault "$prog" ${+"$@"}
thats while attempting to start firefox.

Code:

:~>startkde
xset: bad font path element (#113) possible causes are:
              Directory is missing fonts.dir
..
Gtk-WARNING **: Unable to locate loadable module in module_path: "libqtpixmap.so",

I looked in /usr/X11R6/lib/X11/fonts/and all the directories have 0 in fonts.dir.

l00zer 01-25-2005 06:05 PM

YAY! fixed it! it seemed as if the font directories got messed up somehow. :D


All times are GMT -5. The time now is 08:32 PM.