LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-02-2008, 11:00 AM   #1
pyrobob
LQ Newbie
 
Registered: Jan 2006
Distribution: Kubuntu
Posts: 8

Rep: Reputation: 0
Qwerty and Dvorak


When I installed the OS, I was playing with Dvorak, so I chose that as the keyboard layout. Now I've decided I don't like it. I have it switched back on the desktop, but if I'm in a terminal it's still Dvorak, and so is the login window.

How do I fix it?

I'm on Kubuntu hardy

Last edited by pyrobob; 08-02-2008 at 11:04 AM.
 
Old 08-03-2008, 04:55 AM   #2
pusrob
Member
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 494

Rep: Reputation: 35
Where did you set the keyboard layout back? In KDE as a user or in a terminal as root? If you set the layout back in KDE it won't be effective on the other parts of the system, only on your KDE.
 
Old 08-04-2008, 02:00 AM   #3
pyrobob
LQ Newbie
 
Registered: Jan 2006
Distribution: Kubuntu
Posts: 8

Original Poster
Rep: Reputation: 0
that's exactly what I did. How do I fix it in a terminal as root?
 
Old 08-09-2008, 09:05 AM   #4
pusrob
Member
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 494

Rep: Reputation: 35
Hi, I wasn't reachable for a week, but I'm back now.
So. There is a way to set the keyboard layout from console. Open konsole, and type the following:
Code:
mcedit /etc/X11/xorg.conf
This will open the xorg config file. Here search for an entry like this:
Code:
Section "InputDecice"
 Identifier "keyboard0"
 Driver "keyboard"
 Option "CoreKeyboard"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "en"
 Option "XkbOptions" ""
As you can see there is a XkbLayout entry. You need to set this. I think you will find dvorak "instead" of "en" here, so the only thing you need to do, is to set it back to "en" or something else you need. After you set the option, save the config file, exit konsole and reboot X server (with key combination Ctrl+Alt+Backspace). After login window comes you'll have an english keyboard layout.
 
Old 08-09-2008, 09:30 AM   #5
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
This looks as if it is the way to do it:
http://www.howtoforge.com/forums/showthread.php?t=36
second post
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
QWERTY Master + DVORAK master --> Possible? ciden General 5 06-17-2008 03:58 PM
simultaneous dvorak / qwerty Dranorter Linux - Hardware 2 04-17-2008 11:42 AM
How To Type German Using Qwerty Keyboard? lazylogic Linux - General 7 12-29-2007 07:15 PM
qwerty to Dvorak blitzen Linux - Hardware 5 03-23-2004 01:37 PM
non-qwerty Keboard with sarge yelo Debian 1 11-18-2003 08:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration