LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2017, 06:39 PM   #1
KMCarpenter
Member
 
Registered: Mar 2017
Posts: 64

Rep: Reputation: Disabled
Quick question about keyboard characters


Hello.

On my system, in the GUI, @ shows up as @ like it's supposed to. It even works fine in the GUI terminal. But when I switch over to an actual terminal (Ctrl + Alt + F#), @ shows up as ". How can I fix this?
 
Old 03-30-2017, 08:20 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,386
Blog Entries: 27

Rep: Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405
I don't have an answer, but I have an idea for a diagnostic to get started with.

Run the locale command in a terminal under the GUI, then run the same command in the actual console, and check for differences in the output, particularly as regards the LANG setting.

I'd be mildly taken aback if there were, but it will take only seconds to check.
 
Old 03-30-2017, 08:26 PM   #3
KMCarpenter
Member
 
Registered: Mar 2017
Posts: 64

Original Poster
Rep: Reputation: Disabled
Both the same....
Quote:
LANG=en_GB.UTF-8
LANGUAGE=
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
 
Old 03-30-2017, 09:23 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,386
Blog Entries: 27

Rep: Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405
Drat.

Well that rules out that the desktop environment was somehow invoking a different LANG setting from the raw GUI.

This is curious and I've made myself a note to do some testing tomorrow, but keep in mind that something might come up. In the meantime, if this is a desktop and if you have a spare keyboard, try swapping out the keyboard to make sure it isn't some keyboard weirdness. I do not think it could be, but it's worth ruling out (see my siggy).
 
Old 03-30-2017, 09:29 PM   #5
KMCarpenter
Member
 
Registered: Mar 2017
Posts: 64

Original Poster
Rep: Reputation: Disabled
I have all Cisco keyboards... I swapped one out and got the same results.
 
Old 03-30-2017, 09:42 PM   #6
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,386
Blog Entries: 27

Rep: Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405
Even if they are all Ciscos, I'd expect that, if they were different models, the test should have turned up something. I wouldn't have expected it to be the keyboard in any event, but that's another possible cause ruled out.

For a moment, I thought that xev might help, but xev requires X.

By the way, what distro/version/desktop are you using?

Last edited by frankbell; 03-30-2017 at 09:46 PM.
 
Old 03-30-2017, 09:54 PM   #7
KMCarpenter
Member
 
Registered: Mar 2017
Posts: 64

Original Poster
Rep: Reputation: Disabled
It's the newest stable release of Raspbian
 
Old 03-30-2017, 10:04 PM   #8
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,386
Blog Entries: 27

Rep: Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405
I don't have Raspbian for testing, but I will test on what I have and report back.

Do you have problems with any other characters?

Last edited by frankbell; 03-30-2017 at 10:06 PM.
 
Old 03-30-2017, 10:08 PM   #9
KMCarpenter
Member
 
Registered: Mar 2017
Posts: 64

Original Poster
Rep: Reputation: Disabled
To my knowledge... this is the only problem... I went down all the shift characters and they all worked except for @
 
Old 03-30-2017, 10:30 PM   #10
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
$ sudo dpkg-reconfigure keyboard-configuration

AFAIK, the raspbian defaults to a british keyboard layout. Pipe [|] and number [#] are not what they should be with that layout. Although it is odd that your GUI differs for it's layout.
 
Old 03-31-2017, 04:19 AM   #11
GazL
LQ Veteran
 
Registered: May 2008
Posts: 5,920

Rep: Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894Reputation: 3894
Quote:
Originally Posted by Shadow_7 View Post
Although it is odd that your GUI differs for it's layout.
Not all that odd. Keyboard layout for the gui is set in xorg.conf, though some desktop environments may override this with their own settings, keyboard layout for the console is usually set from a loadkeys command somewhere in one of the rc.* scripts (and will vary with distro). I've no idea what systemd does.

And yes, this sounds very much like a uk <> us layout mismatch.
 
Old 03-31-2017, 09:23 AM   #12
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,386
Blog Entries: 27

Rep: Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405Reputation: 5405
I have not been able to duplicate this on Mageia v. 5 (Zareason laptop), Slackware --Current (Zareason desktop), or Debian v. 8 (Lenovo graphics tablet).

I did learn that if you try ALT-CTRL-BackSpace (I know, it was stupid, but mistakes are how I learn) in a VM, the Host OS intercepts the command and closes X.
 
Old 03-31-2017, 11:42 AM   #13
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
I did that during the rackspace challenge at a texas linuxfest. I don't normally do VMs as all my machines are already resource starved with 2GB ram or less. A lot of distros these days actually disable the Cntrl+Alt+Backspace option to close X. Which is why I found it surprising that it worked in that scenario.

One odd thing I do is use Xdmx to lock several Xephyr windows together so I can have a terminal with a LOT of $LINES. Which helps when coding as I can keep my 1080p screen orientated at 16:9. Anyway, with Xephyr you can lock your input to the Xephyr window with Cntrl+Shift, perhaps that works for a VM to. And toggle out of it with the same. When locked, your inputs do NOT go to your host X environment. I really need to make that youtube video, but my blog on here outlines the process. With a neep font at 6x13 you could have 105x246 characters in an xterm with a fair amount of padding. Which should be good enough to show the full ps output in top if you're not running a server. And the full manpage on one screen for quite a few things.
 
Old 03-31-2017, 11:44 AM   #14
Peverel
Member
 
Registered: May 2009
Location: Chelmsford, England
Distribution: OpenSuse 12.2 and 13.2, Leap 4.2
Posts: 128

Rep: Reputation: 24
You don't say what distribution you are using. but run this through Google

"linux change keyboard language"

and see if any of the answers fit.
 
Old 03-31-2017, 12:19 PM   #15
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,769

Rep: Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133Reputation: 2133
You've obviously got the USA driver instead of the UK one. Sometimes confusion occurs because the X driver is called gb but the console one is called uk! The command
loadkeys uk
should get the correct settings. If it does, you can make a permanent change with
dpkg-reconfigure console-data
I don't know if that still works in the age of systemd; if it doesn't, see this
http://wiki.archlinux.org/index.php/...ion_in_console
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard inputs same characters? yuxingpiao Linux - Hardware 0 06-12-2008 03:25 AM
Keyboard characters netchtech Linux - Software 2 03-23-2006 04:59 AM
Typing Characters Not on the Keyboard Kamex Linux - Software 1 03-02-2005 03:56 PM
Keyboard Characters barneyrockz Linux - Hardware 3 03-01-2005 09:57 AM
Special characters on keyboard adircalam Mandriva 3 09-28-2004 07:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration