LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-17-2002, 08:29 PM   #1
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Rep: Reputation: 15
Question Queston on eth0 I don't understand


Hi,

I have a queston on eth0. In booting int says,
Start Servece eth0
Bring up Interface eyh0: Determining IP information for eth0:0 FAILED

I think my ethernet card is working. How san I be sure?
I an a very NEW newbie I don't understand what IP is looking for? can some tell me.


Last edited by wbheinkel; 01-17-2002 at 08:31 PM.
 
Old 01-17-2002, 09:01 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
it seems your ethernet is working, it just can't find the information to gain network access.. are you on a lan or cable modem or something.. ?? its trying to get the IP info but can't...

tell us what kind of network your on and we might be of some help.

you can use ifconfig eth0 to view your ethernet settings and connection. man ifconfig for more info...
you can use netconfig for set your network settings for your ethernet as well...
 
Old 01-18-2002, 10:55 AM   #3
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for the reply. Right now I have my computer duel booted WinME/Redhat 7.2 and my son on Win95. We are useing modem sharing and sharing files, and sharing my printer.

I would like to use my computer on Redhat 7.2 and share with my son's on win95.

One other thing I tryed to use the command ifconfig from the Console it says bash: ifconfig : command not found. I have tryed other commands in the last few days and they all say "command not found". I know these commands are executabe. I typed su and went to supper user but they still don't work.

I want to thank you and all the other on this form. It is a lot of help to me and the other Newbies. I try to read the manuals but a lot I don't understand. I have worked on MS products for the last 15 years and I think I may be brain dead.

Last edited by wbheinkel; 01-18-2002 at 11:05 AM.
 
Old 01-18-2002, 12:17 PM   #4
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Smile

I found I had to logged it to root. I thought it would work under su (Super User).

Any way ifconfig says,

lo Link encap:Local Feedback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 METRIC:1
RX packets:313 errors:0 dropped:0 overruns:0 frame:0
TX packets:313 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelin:0
RX bytes:20350 (19.8 kb) TX bytes:20350 (19.8 kb)

ifcomfig eth0 says,

eth0 Link encap:Ethernet HWaddr 000:09:38:92:B4
BROADCAST MILTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelin:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interupt:10 Base address:0x8f80

Last edited by wbheinkel; 01-18-2002 at 12:54 PM.
 
Old 01-18-2002, 12:31 PM   #5
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
ok.. so it appears your eth0 is working and being detected.. just not getting network access.. is the ethernet connected via cble modem.. etc ?? most likely its not getting the IP info due to incorrect settings.. try running netconfig as root to check your settings for your type of connection.

oh, and if you usually just type su and then asks for password, that is why your getting command not found.. usually if you do a su root or su - , you will have the commands in your path..

Last edited by trickykid; 01-18-2002 at 12:35 PM.
 
Old 01-18-2002, 01:01 PM   #6
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
My ethernet is connected to a HUB thru a twisted pair.

Last edited by wbheinkel; 01-19-2002 at 10:42 AM.
 
Old 01-19-2002, 11:09 AM   #7
aford
LQ Newbie
 
Registered: Jan 2002
Location: England
Distribution: RedHat 7.1
Posts: 11

Rep: Reputation: 0
A network can be configured either with a static IP address or a dynamic address. Your configuration seems to suggest the latter. This depends on the availbility of DHCP server, which for your needs is not required.

Therefore log-on as root and at prompt type 'setup', under RH 7.1 this will bring a menu driven config program. An option network configuration should be shown in there enter a required IP address for your card.
 
Old 01-19-2002, 07:21 PM   #8
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for the replys. I just wanted to setup my Linux to network with my son's win95. I now think should remove my netconf, the ethernet., try to setup Samba What do you think?
 
Old 01-23-2002, 10:48 AM   #9
eboggess
LQ Newbie
 
Registered: Jan 2002
Distribution: SuSE 9.2 Professional
Posts: 27

Rep: Reputation: 15
Hi...
Before you will be able to use Samba, you will need to get your TCP/IP stack working on your Linux box. That means getting a valid IP address assigned to your /dev/eth0 NIC (Network Interface Card). As user aford suggests, you need to either statically assign an address to eth0 or use DHCP. That being said, I believe you can use your Win95 box to serve up IP addresses (as a DHCP server). In fact, I have a Win98 box doing this exact same thing. You will want to do a search on Microsoft's web site on the "Internet Connection Sharing Wizard" and "Internet Connection Sharing" protocol. They have detailed instructions for setting this up. In addition, you may want to consult a recent thread I started that detailed the Linux side of setting this type of network configuration up. That thread is entitled, "Configure Red Hat 7.2 Workstation as DHCP Client." Once you iron out the TCP/IP issues and establish network connectivity between your Win95 and Linux boxes, then you can work on making your Linux box a Samba client. I hope this helps. Good luck! By the way, you can try /sbin/ifconfig and execute that as a general user. In addition, you will want to look into using the su -c command to use the root account for a single command. Once you do this, you can use find to discover the exact path to a command, since you were having path issues in finding commands earlier. Again, good luck and persevere!!!
 
Old 01-26-2002, 06:48 PM   #10
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Thank for the reply.

When I set my NIC to static and when I boot the eth0 says it is ok. But with it set to static my internet browser can not find the web pages. If I set the NIC to dynamic (DHCP) the browser works fine but the eth0 fails on boot as I said at the begining. I am at a loss why does eth0 not find a IP in DHCP. I hope you can tell me.




Last edited by wbheinkel; 01-26-2002 at 06:52 PM.
 
Old 01-26-2002, 07:37 PM   #11
tiamat
LQ Newbie
 
Registered: Jan 2002
Location: Sweden
Distribution: Redhat
Posts: 17

Rep: Reputation: 0
Quote:
Originally posted by wbheinkel
Thank for the reply.

When I set my NIC to static and when I boot the eth0 says it is ok. But with it set to static my internet browser can not find the web pages. If I set the NIC to dynamic (DHCP) the browser works fine but the eth0 fails on boot as I said at the begining. I am at a loss why does eth0 not find a IP in DHCP. I hope you can tell me.



Static IP is when you use the same IP everytime you boot.

Im guessing you are trying to use the modem for viewing webpages, now you told us you are connected via a HUB.

There is 2 options here as i see it, for us to be able to help us answer theese questions.

a) Do you get your IP via DHCP from your ISP?
b) Do you connect to your ISP with the Windows box or your Linux box?


Since your ifconfig dont show any PPP setup, im guessing you use the windows machine for the internet connection.

This means, you will have to go through the windows box. Which means you want a static IP adress. IE. 192.168.1.1 and then you need to setup the windowbox to have a static ip on the same network, 192.168.1.2.

this means the windows and linux machine will be able to communicate. However i suggest you do it the other way around.

Your LAN (local network) needs to have static IP's within same network (192.168.1.x).

Start by setting up a PPP (modem) connection with your Linux machine. When you got that working move on to your local network.

a) Setup windows box to have your linuxmachine as default gateway.

b) Set windows IP to 192.168.1.2

c) Set your Linux box IP static to 192.168.1.1

d) Enable IP forwarding on Linux machine.

there is plenty of documentation on each of the steps, but this should get you going in the correct direction.
 
Old 01-27-2002, 10:47 AM   #12
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by tiamat


Static IP is when you use the same IP everytime you boot.

Im guessing you are trying to use the modem for viewing webpages, now you told us you are connected via a HUB.

There is 2 options here as i see it, for us to be able to help us answer theese questions.

a) Do you get your IP via DHCP from your ISP?
b) Do you connect to your ISP with the Windows box or your Linux box?


Since your ifconfig dont show any PPP setup, im guessing you use the windows machine for the internet connection.

This means, you will have to go through the windows box. Which means you want a static IP adress. IE. 192.168.1.1 and then you need to setup the windowbox to have a static ip on the same network, 192.168.1.2.

this means the windows and linux machine will be able to communicate. However i suggest you do it the other way around.

Your LAN (local network) needs to have static IP's within same network (192.168.1.x).

Start by setting up a PPP (modem) connection with your Linux machine. When you got that working move on to your local network.

a) Setup windows box to have your linuxmachine as default gateway.

b) Set windows IP to 192.168.1.2

c) Set your Linux box IP static to 192.168.1.1

d) Enable IP forwarding on Linux machine.

there is plenty of documentation on each of the steps, but this should get you going in the correct direction.

In answer to your questions.

a) I think I get my IP via DHCP from my ISP.
b) I connect to my ISP through my Linux box.

There are so many option in Linux so I here is a lot I don't understand. Right now I have my network set to dynamic (DHCP) and have ppp(modem) connection on my linux box. With this setup I can view webpages fine.

My box is duel booted WinME and RedHat 7.2. When I am booted to WinMe I am networking to my son's Win95 Box where we share files and a printer. I would like to do the same with me booted to RedHat 7.2 and still be able to use my modem.

I will try your suggestions the one thing I don't understand is how to enable IP forwarding on my Linux box. I have only been on Linux for less than two weeks but I will learn Thanks to everyone's help.

Thanks again.
 
Old 01-27-2002, 10:17 PM   #13
tiamat
LQ Newbie
 
Registered: Jan 2002
Location: Sweden
Distribution: Redhat
Posts: 17

Rep: Reputation: 0
Ok.

This is what you should do.

You do NOT want DHCP on your network (eth0).

eth0 should have IP 192.168.1.1 (this ip will be yout internal network between you and your sons computer). Set your Netmask to 255.255.255.0. Also enable ipv4 forwarding. All theese settings can be done in the X network configurator that came with your Linux installation.

Second on your sons computer set IP to 192.168.1.2. Netmask to 255.255.255.0.
And default gateway to 192.168.1.1 (since he will be using your computer as gateway to internet.

Then you need to setup IPchains to forward the traffic from eth0 to ppp. Ive prepared a script for you to do this. Download it from Here
. The script (named firewall.sh) is setup to forward ALL traffic from eth0 to ppp0 which means all traffic from (192.168.1.2) will be directed out to PPP0.

All you have to do is to save it somewhere in root's path and run it in a shell.
ie. save it in /root/ then do this at prompt as root.

chmod 700 ~/firewall.sh
~/firewall.sh

You will need to have ipchains installed and the service running though for this to work. Refer to your manual.

Good luck.
 
Old 01-28-2002, 01:51 PM   #14
wbheinkel
LQ Newbie
 
Registered: Jan 2002
Location: Bonita Springs, FL
Distribution: Mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by tiamat
.


Then you need to setup IPchains to forward the traffic from eth0 to ppp. Ive prepared a script for you to do this. Download it from Here
. The script (named firewall.sh) is setup to forward ALL traffic from eth0 to ppp0 which means all traffic from (192.168.1.2) will be directed out to PPP0.

All you have to do is to save it somewhere in root's path and run it in a shell.
ie. save it in /root/ then do this at prompt as root.

chmod 700 ~/firewall.sh
~/firewall.sh

You will need to have ipchains installed and the service running though for this to work. Refer to your manual.

Good luck.


It would not let me download the script "firewall.sh" It told me I didn't have permission to access.

Useing netcomfig I set it to 192.168.1.1 and thr rest the defaults. I edited the file/etc/sysctl and added.

# Enable packet forwarding
net.ipv4.ip_forward = 1

I set my son's windows box to 192.168.1.2 and the gateway to 192.168.1.1.
I was able to ping my son's box (192.168.1.2) to my Linux box (192.168.1.1) OK. Also the from the Linux box to my son's OK.

My PPP connects OK but am unable to view webpages.

This is maybe because I have not I don't have the firewall.sh yet. If to want you can e-mail it to me from this thread.


Last edited by wbheinkel; 01-28-2002 at 05:31 PM.
 
Old 01-28-2002, 06:28 PM   #15
tiamat
LQ Newbie
 
Registered: Jan 2002
Location: Sweden
Distribution: Redhat
Posts: 17

Rep: Reputation: 0
Doh.
Changed rights try again on same link
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
a queston about SSH.. jsnch Linux - Security 7 07-05-2005 07:59 PM
last queston...???antivirus for linux banana2 Linux - Software 3 03-29-2003 12:11 PM
apsfilter queston.... hjles Slackware 8 02-16-2003 04:39 PM
math queston linuxhelp Linux - General 3 12-17-2002 03:36 PM
Ethereal-0.9.3 installation queston. jpweston Linux - Software 2 04-16-2002 12:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration