LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-05-2007, 09:55 PM   #16
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30

Hey my friend, it's been a while!! I had put that aside for a while, but now I am back for more!

Ok I know my haupauge works, cause I get a "no channel video" when I type

mplayer /dev/video0

Now, When I do mysql --user=root --password=passwordSETearlier < /usr/share/doc/mythtv-0.20/database/mc.sql, it tells me that the file doesnt exist... What should I do? Im pretty lost in that mysql thing...

Thanks!
 
Old 10-06-2007, 09:38 AM   #17
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
bump.............
 
Old 10-08-2007, 11:06 AM   #18
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
How do you know your hauppauge works? You should get video of some sort when you run mplayer (at least I do).

As for the mysql thing, what exactly are you trying to do? Do you need to reset the mysql password?
 
Old 10-08-2007, 04:48 PM   #19
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
I know it works because I have something when I type mplayer /dev/video0

What I am trying to do with mysql is the following:

Configuration
To setup mythtv’s backend, we’re going to run myth-setup (that’s the command you can run from a konsole as well). This will ‘setup’ our configuration for when we fire up the mythbackend. However, we need to give the MySQL database structure so that the data can be stored inside of it. To do this, MythTV gives you a .sql file that can be used to form the database structure.
CODE:
[root@localhost~]# su
CODE:
[root@localhost~]# mysql --user=root --password=passwordSETearlier < /usr/share/doc/mythtv-0.20/database/mc.sql
Now the structure is complete. It’s time to run the setup utility.

TAKEN FROM:

http://linux-blog.org/index.php?/arc...nd-MythTV.html
 
Old 10-08-2007, 04:53 PM   #20
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
You need to find where mythtv put that database structure file. Go poke around the /usr/share/doc/ directory. Maybe your directory is mythtv-0.20.2 or something different. Basically the end that string "</usr/share/doc/mythtv-0.20/database/mc.sql" is inputting the file mc.sql into mysql. So you probably just need to find the file mc.sql.
 
Old 10-09-2007, 09:05 PM   #21
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
Ok... but here's a good one for you. How come this happens?
Code:
[root@localhost Desktop]# mysql --user=root --password=**** < /usr/share/doc/mythtv-0.20/database/mc.sql
bash:  /usr/share/doc/mythtv-0.20/database/mc.sql: No such file or directory
[root@localhost Desktop]# ls -l /usr/share/doc/mythtv-0.20/database/
total 4
-rw-r--r-- 1 root root 298 Jan 20  2006 mc.sql
[root@localhost Desktop]#
????????
 
Old 10-10-2007, 11:01 AM   #22
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
What are the contents of mc.sql (i.e. cat mc.sql)?

Also, you could try and cd to the directory, and then do
Code:
mysql --user=root --password=**** < ./mc.sql

Last edited by pljvaldez; 10-10-2007 at 11:44 AM.
 
Old 10-10-2007, 04:42 PM   #23
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
OK!!!!

We are making progress here big time... CD to directory actually solved the problem.. stupid me, must have been a space or something. Anyways, I was able to go through the setup (it sees my USB2 decoder on /dev/v4l/video4 (something like that) and I was able to start mythfrontend. But when I click on WATCH TV, I get an error telling me the mythbackend is not started.... I previously did service mythbackend start and it said ok... What can I try now? I have only a laptop, and from what I understand, backend would be needed if I was trying to watch tv on another computer?

Thanks man:P
 
Old 10-10-2007, 05:30 PM   #24
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Are you trying to start the frontend on the same machine as the backend? If not, I remember reading something about needing to setup mysql for network access.

Currently, I have the frontend on the backend machine, so I didn't bother setting it up for network access.

What is your setup like? Is the backend server on the laptop as well? Mythtv is like every other linux client server setup. The server always needs to run. Sometimes the client is on the same machine. Just like you could install apache on your laptop and serve web pages to firefox running on the same laptop.
 
Old 10-10-2007, 08:45 PM   #25
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
Well, as I stated, my backend service is running... That is why im wondering if there is anything else I should setup in the menus... I typed

Code:
[root@localhost database]# service mythbackend start
Starting mythbackend:                                           [  OK  ]
any ideas? My setup is everything on my laptop, plain and simple.
 
Old 10-10-2007, 08:49 PM   #26
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
It says:

Cannot connect to the master backend server. Is it running? Or the IP address is correct in the setup?


Do I have to change something in the IP adress setup if its on the same computer?
 
Old 10-11-2007, 12:29 PM   #27
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Did you run mythtv-setup? If not, stop the backend and then run mythtv-setup. Make sure the ip address is localhost (127.0.0.1).
 
Old 10-14-2007, 02:41 PM   #28
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
Hey pljvaldez, I found this on another forum, and I think it might be the problem.

Looks like the age-old database problem again.

What do you think the 'mythtv' mysql user's password is? Can you log in to mysql using
Code:
mysql -u mythtv -p mythconverg
??

If you can't log in using that then the mythtv mysql user's password is set to something you don't know.

Either 1. look in /etc/mythtv/mysql.txt to find out what it is or 2. change the mythtv mysql user's password to something more memorable and update all occurances of mysql.txt files to reflect the new login details.


Now, what do I have to do to change the password of mysql? Because I cannot log in using user "root" and my password? Thanks!
 
Old 10-14-2007, 03:33 PM   #29
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
I'm trying my best to change the password like the following, but it always gives me a syntax error... Where am I wrong?

ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '’****’' at line 1
mysql> SET PASSWORD FOR root@localhost=PASSWORD ’****’;
 
Old 10-15-2007, 07:40 AM   #30
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Not a Mysql server guy. But I used this link to set the passwords the way I wanted. Since I don't use PCLinuxOS, I can't tell you if that is the correct "stop" command for stopping mysql.

Also, I usually do this line after the root user password update
Code:
mysql>UPDATE user SET Password=PASSWORD('mythtv') WHERE User='mythtv';
Also, realize that this is just the mysql database password. So when you enter a password for 'root', don't use the same root password as your system root password.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
qmake not found on debian 4 mperez Debian 17 05-16-2007 01:52 PM
qmake: command not found after apparently flawless Qt install emiphiste Linux - Software 6 12-13-2006 06:16 PM
bash: rpm: command not found && sudo: alien: command not found Java_Code Ubuntu 7 07-27-2006 11:57 PM
qmake not found ??? rooman Linux - General 0 11-01-2004 05:04 AM
qmake not found Mestax Linux - Newbie 2 09-06-2003 11:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration