-   Linux - Newbie (
-   -   Puppy- Dual boot XP: can't boot either (

FitBoot 08-27-2012 08:27 PM

Puppy- Dual boot XP: can't boot either
Much of the info involved is listed under prior thread title "MINT Install from Live CD"
Finally, on advice re: my older system, I obtained Puppy, love the look and feel, installed from liveCD.
Cannot get either OS to boot now and seriously need help.
I was ready t drop Linux off a cliff a few days ago (it's been a months' long struggle now/

My menu.lst file and the txt file report from BootInfoscript are now posted at (posted 8/27, Titles are FitBoot)

Can someone who truly knows the correct syntax and language, what should be in these files and how to correct any errors, please respond and give me some help with this.
I know this shouldn't be this hard but terribly frustrated with the massive hoops I'm having to jump through to get to the wonders of Linux.

Helpful advice, please!!
Thank you for your help,


yancek 08-27-2012 09:43 PM

Your bootinfoscript shows you installed Grub Legacy to the master boot record of sda, your windows drive. It is pointing to sdb1 to look for the menu.lst file and the stage2 file. It doesn't show any stage2 file and the menu.lst is not a standard Grub Legacy one so I assume that is from your Grub4Dos that you have installed to the mbr of sdb, correct? The menu.lst file looks like a combination of Grub Legacy and Grub2. Never used Grub4Dos but maybe someone will come along who is familiar. Otherwise, you could just install the Puppy Grub Legacy to the mbr of sdb or to the mbr of sda. Not really sure what your intentions are?

FitBoot 08-28-2012 10:43 AM

Update questions
Thank you so much for your insight.

I'll search for someone with some more knowledge of Grub4Dos but thatnk you fo properly reading my menu.lst file.
Do you think that some problems can be solved by simply intalling Grub to sdb?
I was advised to go to Grub4Dos when earlier Grub work wasn't going well (getting partitions recognized, etc.)
Perhaps the deal w/Grub4Dos is that it issome sort of hybridamong Grub Legacy, Grub2, etc so that the older system can work?
But it doesn't seem it should be creating duplicate systems or leaving files in the worng place (if at all).

Do you think I should just reinstall grub at sdb?
How should I go about recreating the stage2 file or will it do that on its own?

My intentions are simple: install Puppy on sdb2, a 200G HD, and get it to run properly alongside XP on 40G HD) so I can get some work done.
That's it really.

Any further advice or suggestions for where else to look appreciated. This is way too long for allgedly simple stuff.
Thank you verymuch!


yancek 08-30-2012 10:43 AM

Probably the simplest would be to install the Puppy grub to sdb. Boot the Live CD and verify the drive partition names from Grub. You can do that by opening a terminal and typing: grub That should give you the grub prompt which looks like this: grub> From there type: geometry (hd0) - hit the enter key to get output. You should see info on your windows drive with ntfs filesystems. Repeat the geometry command and insert (hd1) and you should see information on your Puppy drive. This is simply to verify that sdb is the Puppy drive as seen by grub. If that is correct, you should be able to install Puppy Grub with the following commands, hit Enter after each command from a grub prompt:
root (hd1,1)
setup (hd1)

That should install Puppy Grub to the mbr of sdb pointing to the Puppy boot files on sdb2. If you have sda with windows set to first boot priority in the BIOS, you will need to select sdb on boot to boot Puppy.

FitBoot 09-08-2012 02:11 PM

Yancek,Thank you so much for all your previous help!

Finally after finding Lin 'n Win, I've got the options back on bootup to start XP or Puppy and feel that I am very close to having everything runnable as I think it can be.

Ok, current problem: getting
Error 17: cannot mount selected partition
when I select Linux Puppy to boot.
Puppy, of course, is on sdb2. Boot partition is sdb1

Tried your latest instructions for installing Grub to hd1.
Using LXTerminal, got past root (hd1), setup (hd1) returned
cannot mount selected partition

Tried PMount and mounted sdb1.
Still same responses.

So everything is loaded, and I think I know where it all is.
Just can't seem to get in to Puppy except with LiveCD.

Any further help you have will be very much appreciated. I don't know what's wrong now or how to fix it.
Thank you!


yancek 09-08-2012 04:36 PM

Do you actually have a separate boot partition for Puppy?
The root command you posted should be: root (hd1,0) if you are trying to get to sdb1 and (hd1,1) if the boot fiels are on sdb2. Can't imagine why you would create a separate boot partition for Puppy??

Post the output of: fdisk -l (lower case letter L in the command)

FitBoot 09-08-2012 07:26 PM

Tried all the listed iterations for the root . . . setup. . . exit listing.
I get
Syntax error near unexpected token (hd1,0)

NOTE: I setup a boot partition earlier when partitioning the drives as I tried to get Ubunutu and then Mint. As far as neatly using space, though Lin 'n' Win didn't call for it, I left the boot partition separate.

Results from fdisk:

Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 1663 13350016 7 HPFS/NTFS
/dev/sda2 * 1664 4865 25720065 7 HPFS/NTFS

Disk /dev/sdb: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 6374 51199123+ 83 Linux
/dev/sdb2 6375 24321 144159277+ f W95 Ext'd (LBA)
/dev/sdb5 6375 12749 51207156 83 Linux
/dev/sdb6 12750 24321 92952058+ b W95 FAT32

Appreciate the help. Thank you so muh.
I'd just like to get into this thing. It ran earlier by itself (Frugal Install), just can't get it up with the dual boot.

Thank you very much!


yancek 09-08-2012 08:06 PM

Boot the Puppy CD. Open a terminal and create a mount point for sdb1: mkdir /mnt/sdb1
Then mount it: mount -t ext3 /dev/sdb1 /mnt/sdb1
Then look at the files there and post: ls /mnt/sdb1/

Repeat this for sdb2 so we can see where the boot and kernel files are.
When you run the geometry commands I suggested previously from the Puppy CD from the grub prompt: geometry (hd1)
does that show Linux filesystems. It should be similar to the output below, the first is windows, the second is Linux:


Partition num: 2, Filesystem type unknown, partition type 0x7
Partition num: 4, Filesystem type is ext2fs, partition type 0x83
The Grub error 17 usually occurs when it is trying to mount a windows filesystem.

FitBoot 09-08-2012 09:44 PM

Okay, I'll check, but whoa, what's this geometry command? (remember, you're coaching newbies and Linux command language need is extensive and quite complex . . compared to GUI life).

From terminal, what exactly must I do to get the info you request.

Thank you,Yancek


FitBoot 09-08-2012 10:14 PM


Okay, sorry didn't realize the command was right there and I just had to run it in grub.

Output for sdb1 was:

grub> geometry (hd1)
drive 0x81: C/H/S = 24321/255/63, The number of sectors = 390721968, /dev/sdb
Partition num: 0, Filesystem type is ext2fs, partition type 0x83
Partition num: 4, Filesystem type is ext2fs, partition type 0x83
Partition num: 5, Filesystem type is fat, partition type 0xb

Geometry for hd0: (it refuses to recognize sdb2 in these attempts, so I assume perhaps this is another reason I can't get in -- have I listed all this wrong in menu.lst?)

grub> geometry (hd0)
drive 0x80: C/H/S = 4865/255/63, The number of sectors = 78165360, /dev/sda
Partition num: 0, Filesystem type unknown, partition type 0x7
Partition num: 1, Filesystem type unknown, partition type 0x7

I hope you can get something useful from this listing. Please advise.
Thank you so much for your attention, diligence, and patience.


FitBoot 09-10-2012 10:54 PM

Puppy XP updates - unable to boot puppy
hELLO, ALOkay, the update to my troubles.

Afte Yancek's guidance, I posted the reults from his Geometry request.

Currently, I can successfully boot XP, which is a relief.
However, even after attempt at Lin'n'Win's walkthrough to reinstall Puppy (Frugal Install), I cannot get it to boot.

Error 23: error parsing number
Press any key to continue

Any assistance with this problem is appreciated. I even restored an earlier XP in case the parsing werror was coming fomr some Windows malfunction, but no joy.

I have chosen not to run the PC-fix software referred to in a few forums as the issue seem to me to be coming from Grub v. XP since XP boots fine now.

Please provide what knowledge and assistance you can. I think Ilost Yancek u8nfortunately.
Thanks very much for your assistance! For what is supposed to be this small and very simple software, I just can't understand why it's all oon my machine but I can't seem to get Puppy to square itself away and run peacefully alongside XP. Almost done with this experiment, though I really do want to keep trying Linux and get it to work. It all seems like a good idea. . . just nopt as simple as it's s'posed to be.


FitBoot 09-12-2012 02:48 PM

Fixed it
Well, I finally got it!

After much hand-wringing and despair, I chose to wipe the drive, get rid of the (too many) partitions given I was trying to use Puppy, created only one small partition on the C: drive (sda1), and reinstalled Puppy.

For those still trying to figure things out:
  • Puppy is a great distro for the older computer with limited RAM - light and light on required resources
  • Go to the instructions at Lin'n'Win. He's done an excellent job with conciseness and specific instructions esp. with the menu.lst file and what you need
  • Alter your menu.lst to show your boot options as you want them in the order in which you want them
  • And as you seek help and advice, keep at it and do your research. Linux can be very helpful - find a great user manual and explanations in "The Puppy Linux Book" by Grant Wilson online. The community is full of knowledgeable folks as well as the unfocused and overly opinionated on OSes, so you must wade in patiently. But I feel it is a language that can be learned with some dedication.

Thanks to all for their support and assistance.
I wish you all who still have issues the best with their resolution!


All times are GMT -5. The time now is 10:45 AM.