LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-09-2007, 03:19 AM   #1
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Rep: Reputation: 30
program 'su' is not found


I'm running Kanotix with kernel 2.6.16.16-kanotix-1 and am getting the following errors:

When trying to run a pgm that requires root access (e.g. synaptic), kdesu pops up, I enter the root password and then get this error message:
The program 'su' is not found;
make sure your PATH is set correctly.

When I try to open a console, I get this merror message from Konsole:
Konsole is unable to open a PTY (pseudo teletype). It is likely that this is due to an incorrect configuration of the PTY devices. Konsole needs to have read/write access to the PTY devices.

I've googled both errors but haven't been able to find a solution. Can anyone help, please?

Thanks
Joe
 
Old 01-09-2007, 03:31 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,896

Rep: Reputation: 352Reputation: 352Reputation: 352Reputation: 352
2) check your /etc/password file to see if your default shell has changed from /bin/bash to something else.

1) after correcting that entry, from a console, run 'which su' to get the path to the su executable. Add it your your PATH variable.

PATH=$PATH:/bin/su

Last edited by bigrigdriver; 01-09-2007 at 03:35 AM.
 
Old 01-09-2007, 03:39 AM   #3
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Thanks for the suggestions, but ...

In etc/passwd it's still /bin/bash

'which su' (from Ctl-Alt-F1) gives this output: /bin/su

echo $PATH (also from Ctl-Alt-F1) gives this output: /sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/usr/local/sbin:/usr/local/bin:/usr/games

Any other ideas? I'm getting kinda desperate
 
Old 01-09-2007, 04:33 AM   #4
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Try
Code:
ls -ld /bin
ls -l /bin/su
and post the results.

Your $PATH does seem to include /bin, so that should be OK. Unless a chroot is involved, of course.

Last edited by timmeke; 01-09-2007 at 04:35 AM.
 
Old 01-09-2007, 04:40 AM   #5
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
ls -ld /bin:
drwxr-xr-x 2 root root 2648 Jan 8 10:04 /bin

ls -l /bin/su:
-rwsr-xr-x 1 root root 27000 Dec 7 19:28 /bin/su
 
Old 01-09-2007, 06:06 AM   #6
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
OK. Seems fine too.

Code:
ls -ld /
cat /etc/fstab
 
Old 01-09-2007, 06:54 AM   #7
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
ls -ld:
drwxr-xr-x 23 root root 560 Jan 4 10:32 /

cat /etc/fstab:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
/dev/sda1 / reiserfs defaults 0 1
/dev/sda2 swap auto defaults 0 2
/dev/cdrom /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/cdrom /media/hdc udf,iso9660 user,noauto 0 0
/dev/sdb1 /media/sdb1 auto defaults,user 0 0
 
Old 01-09-2007, 07:22 AM   #8
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Did you do this from the console (Ctrl-Alt-F1)? Or from a terminal window?

Did you make any changes to your /home/you/.bashrc or /home/you/.bash_profile?
Or to the systemwide bashrc and profile in /etc?
 
Old 01-09-2007, 07:29 AM   #9
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
I did it from Ctl-Alt-F1. Can't get into a terminal window ...

Haven't made any changes to the other things you mentioned.
 
Old 01-10-2007, 05:24 AM   #10
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Here are the contents of .bashrc in my home directory:

# /etc/bash.bashrc
[ -f /etc/profile ] && . /etc/profile

/etc/bash.bashrc looks like this:

# /etc/bash.bashrc
[ -f /etc/profile ] && . /etc/profile


and /etc/profile looks like this:

# /etc/profile
umask 022
PATH="/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/usr/local/sbin:/usr/local/bin:/usr/games"
[ "$UID" = "0" ] || PATH="$HOME/.dist/bin:$PATH:."
export PATH
# Change PAGER
if [ -x /usr/bin/most ]; then
PAGER=/usr/bin/most
export PAGER
fi
# Set LOCALE
if [ -f /etc/sysconfig/i18n ]; then
. /etc/sysconfig/i18n
[ -n "$LANG" ] || LANG="de_DE@euro"
export LANG
[ -n "$LC_CTYPE" ] && export LC_CTYPE || unset LC_CTYPE
[ -n "$LC_COLLATE" ] && export LC_COLLATE || unset LC_COLLATE
[ -n "$LC_MESSAGES" ] && export LC_MESSAGES || unset LC_MESSAGES
[ -n "$LC_NUMERIC" ] && export LC_NUMERIC || unset LC_NUMERIC
[ -n "$LC_MONETARY" ] && export LC_MONETARY || unset LC_MONETARY
[ -n "$LC_TIME" ] && export LC_TIME || unset LC_TIME
[ -n "$LC_ALL" ] && export LC_ALL || unset LC_ALL
[ -n "$LANGUAGE" ] && export LANGUAGE || unset LANGUAGE
[ -n "$LINGUAS" ] && export LINGUAS || unset LINGUAS
[ -n "$_XKB_CHARSET" ] && export _XKB_CHARSET || unset _XKB_CHARSET

if [ -n "$SYSFONTACM" ]; then
case $SYSFONTACM in
iso01*|iso02*|iso15*|koi*|latin2-ucw*)
if [ "$TERM" = "linux" ]; then
if ls -l /proc/$$/fd/0 2>/dev/null | grep -- '-> /dev/tty[0-9]*$' >/dev/null 2>&1; then
echo -n -e '\033(K' > /proc/$$/fd/0
fi
fi
;;
esac
fi
unset SYSFONTACM
fi
# END LOCALE
# enable bash completion in interactive shells
[ "$PS1" -a -f /etc/bash_completion ] && . /etc/bash_completion
PS1="\u@\h:\w\\$ "
alias ..="cd .."
alias which="type -path"
alias where="type -all"
alias ll="ls -l --color=auto"
alias l="ls -a --color=auto"
alias rm="rm -i"
alias mv="mv -i"
alias cp="cp -i"
alias la="ls -la --color=auto"
alias ls="ls --color=auto"
 
Old 01-10-2007, 06:04 AM   #11
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
So you can't open a terminal window, but you can still use your Linux GUI (the applications in the menu, etc), right?

Can you run "su" from (Ctl-Alt-F1) console? Or does that give you any errors too?

Can you also try (from Ctl-Alt-F1):
Code:
ls -l /dev/pty*
 
Old 01-10-2007, 07:01 AM   #12
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
Yes, I can use the GUI. The only problems I've run into are when a program needs to run in super-user mode (like synaptic) and when I try to open a console.

'su' runs without problems from Ctl-AltF1

ls -l /dev/pty* returns "no such file or directory"

Thanks for your responses thus far. I appreciate it.
 
Old 01-11-2007, 06:14 AM   #13
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Original Poster
Rep: Reputation: 30
***bump***
 
Old 01-11-2007, 06:24 AM   #14
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 165

Rep: Reputation: 23
Is your user name a member of the group "wheel" ?
 
Old 01-11-2007, 06:48 AM   #15
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Can you have a look at /dev/makedev.d/ and search for files that configure your pty's?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
'su' not found after KDE update madgenius SUSE / openSUSE 2 08-17-2006 09:48 AM
ar program not found jeffshen Mandriva 2 03-30-2006 06:05 AM
Problem with 'su' gri6507 Linux - Software 5 06-17-2005 10:11 AM
epsxe + program not found Micro420 Linux - Games 2 10-27-2003 11:07 AM
Can no longer 'su' tisource Linux - General 7 05-04-2003 04:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration