LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Proftpd with plesk on redhat (https://www.linuxquestions.org/questions/linux-newbie-8/proftpd-with-plesk-on-redhat-284985/)

siulung 02-01-2005 01:33 PM

Proftpd with plesk on redhat
 
i am trying to setup a linux server with remote ssh and plesk access only,it have proftpd installed with it.
i need to setup a ftp account on the server to access one of the vhost folder ( /home/vhost/test/httpdoc/somefolder/) and that account can only access such folder only
from plesk web site ---
You need to create system/ftp user, set the home directory for this user to your_domain/some/location and add the user into /etc/ftpchroot file. The user will be 'chroot'-ed to his home only. Do not forget to set directory permissions correctly.

could some of experience user explain to me detaily what to do, i am not too experience with linux, especially with ssh only...

here is the proftpd.conf
-----------
ServerName "ProFTPD"
ServerType inetd
ServerType inetd
DefaultServer on
<Global>
DefaultRoot ~ psacln
AllowOverwrite on
</Global>
DefaultTransferMode binary
UseFtpUsers on

Port 21
Umask 022

MaxInstances 30

configurations
ScoreboardFile /var/run/proftpd/scoreboard

TransferLog /usr/local/psa/var/log/xferlog
<Directory /home/httpd/vhosts>
GroupOwner psacln
</Directory>

Include /etc/proftpd.include
---------
all i can dig up is up to here from here how do i set the user? unlike from the proftpd web site i couldn't figure where the vhost and user...
any help is appericate
thx
P.S. the ftpserver is up and running i can login the ftp with the client plesk setup for me but i don'y know how to customize those account setting and i need to set extra ftp account.

chup 02-06-2005 03:29 PM

If I understand correctly, you need to add a new user to your ftp, and have it's homedir /home/vhost/test/httpdoc/somefolder/. I'm not sure if I'm doing this correctly, but I'll try. You need to:
Change this "DefaultRoot ~ psacln" to "DefaultRoot ~".
Then run "useradd YOURUSERNAME". That will add a user with the name YOURUSERNAME to the system. Set the password for the user by "passwd YOURUSERNAME". Then do "ln -sf /home/vhost/test/httpdoc/somefolder/ /home/YOURUSERNAME". That will link the /home/vhost/test/httpdoc/somefolder/ directory to your new user's homedir. Add the user to sshd-denied users (for security). Then you need to add this to your proftpd.conf:
Code:

<Anonymous ~YOURUSERNAME>
  User                          YOURUSERNAME
  Group                        ftp

 <Limit WRITE>
    DenyAll
  </Limit>
AllowRetrieveRestart on
AllowStoreRestart on
</Anonymous>

That will deny the user all write access, but allow him to download files and resume downloads.

Please note: I think this should work. Check the permissions for the /home/vhost/test/httpdoc/somefolder/ directory. I hope this helps you!


All times are GMT -5. The time now is 01:34 PM.