LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-08-2004, 11:05 AM   #1
elderain
LQ Newbie
 
Registered: Mar 2004
Location: Ohio
Posts: 16

Rep: Reputation: 0
Unhappy Proftpd Issues


Hello,

I just setup a Mandrake Linux 9.2 machine about a month ago. I had everything working and then all of a sudden proftpd decided it doesn't want to accept connections. When I check my running processes it says that proftpd is not running.. In webmin, I start it up and get 'Starting proftpd: [ OK ]'. Then, if I check to see if it's running it still says no. There is also a button there that says 'Show Status' so I click it and it says 'Executing /etc/rc.d/init.d/proftpd status..' and I get 'proftpd dead but subsys locked'.

When I try to connect to the ftp port I get: Connection closed by remote host. My apache server and my SSH server are both working fine, it seems that proftpd is the only server acting up.

Btw, I am running the connection through a router. I have the linux machine set as a dmz host and I have all ports forwarding to it.

Any ideas? You're help would be greatly appreciated.

Thank you,
 
Old 03-08-2004, 11:22 AM   #2
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
personally I don't really like webmin for some modules didn't correctly work for me... dis you try to start a proftp daemon manually? set the option "ServerType standalone" in the config file (probably /etc/proftpd.conf) and start the server with proftpd. if this works, I guess it is misconfigured in the inetd.conf. restore the "ServerType inetd" in the proftpd config file and put something like this

ftp stream tcp nowait root /usr/sbin/tcpd proftpd

in the inetd config file (probably /etc/inetd.conf) and restart inetd by sending it a SIGHUP like this:

kill -SIGHUP <process id of inetd>

hope this helps...
-=iluvatar=-
 
Old 03-08-2004, 06:56 PM   #3
elderain
LQ Newbie
 
Registered: Mar 2004
Location: Ohio
Posts: 16

Original Poster
Rep: Reputation: 0
Talking Thanks!!!

Thanks for the help!! It's working perfectly fine now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd: proftpd startup failed tumana Linux - Newbie 14 06-17-2012 12:06 PM
Issues with Proftpd.. sspiro Linux - Networking 5 09-12-2005 01:06 PM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 11:27 AM
proftpd anonymous login issues jstander Linux - Software 3 05-05-2003 08:11 PM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 07:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration