LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Proftp for anonymous logon (https://www.linuxquestions.org/questions/linux-newbie-8/proftp-for-anonymous-logon-161462/)

VincentB 03-23-2004 02:12 PM

Proftp for anonymous logon
 
All,

I know lots of things have already been written for Proftp (which also means it is not so obvious to install and configure) but ... despite all those messages, I did not find what I am looking for.

I would like to use proftpd on my mandrake 9.2

I just want to allow access (read / write) to 'anonymous' to the /var/ftp/pub directory.
I also want to make sure that any people logged with that 'anonymous user-id' can list/ updload / download / delete files from that (and only that) location.

It currently seems that I can upload file in /var/ftp but, once the upload is ended, the uploaded file is no more visible for the ftp connection. I can read this in the journal :

---------------------

227 Entering Passive Mode (192,168,1,100,129,219)
STOR //my_file_to_transfer

150 Opening BINARY mode data connection for //Compiere_251.tar.gz.
226 Transfer complete.
Transfert réussi de /xxx/yyy/zzz à 98793,70 ko/s
SITE CHMOD 777 ///my_file_to_transfer

550 Operation prohibited for anonymous users.
PASV

227 Entering Passive Mode (192,168,1,100,129,221)

---------------------

But I can see the file when I browse directly in /var/ftp/ from a terminal.

I guess that the error message after CHMOD 777 is a partial explanation.
I use gftp as ftp client.

What do I have to do to make them 'visible' after the upload?
What should the proftpd.conf file looks like?
Do I have to define specific users?

Thanks in advance for your help,

Vincent

adamwenner 05-01-2004 02:30 PM

hey vincent, im not exactly sure about proftpd, but in vsftpd, there is an option to use anonymous access, the rest should be set up in giving anonymous rights and chowning

one thing you could try is

useradd -d /var/ftp/anonymous anonymous

then dont specify a password

again, i dont use proftpd, so i am not exactly sure

then do

chown anonymous /var/ftp/anonymous
then
chmod 700 /var/ftp/anonymous

then in the proftpd.conf file, set the default umask to 002

sorry i cant be more specific

good luck
adam


All times are GMT -5. The time now is 04:22 AM.