-   Linux - Newbie (
-   -   Problems with writing to msdos format flash drive. (

jag022054 11-12-2012 09:29 PM

Problems with writing to msdos format flash drive.
I am running Ubuntu 12.04

I have a flash drive in msdos format. I am having problems writing files to subfolder.
I can read files.
I can create folders.
I can write files to the root directory.

The data initially appears to be OK. After ejecting the drive and remounting it the folder is empty.

What is going on. What can I do to fix this.

floppy_stuttgart 11-13-2012 11:51 AM

run "gparted", menu "check" to see any issue?
what say dmesg after the files are written? do you see errors?
what happens with another one? throw the old one away? (sticks get wear..)

linosaurusroot 11-14-2012 04:16 AM

Are the filenames you are trying to create in the msdos 8.3 format. If not you would need vfat rather than msdos.

jag022054 11-14-2012 10:36 PM

Checked using gparted.
The gparted check seemed to like the fat32 file system on the flash drive. No errors were detected.

In response to the question about the length of the file names being used. The drive contained files and folders with long file names. Gparted shows the file system as fat32, it may realy be vfat as suggested.

I tried reformating and reloading the data. I was able to load data but ran into problems once there number of folders got to be the same number as were originally on the device.

The problem produces no error. Files apear to be copied. They disapear after the device is ejected and remounted. I think this may be the real problem. I think if there were an error message when when these files fail this issue would be a lot less of a mystery.

It looks like part of the problem is limitations in the FAT32 file system or the way it is configured on this device.

I also tried writing a bunch of files into as single directory. I got 317 files to stick. I was able to recreat this a couple of times. Once I hit this limit I couldn't get files in another folder to stick either. When I was doing multiple folders wall seemed to be 27 folders (containing 303 files).

Because the it fails silently I didn't realize when I explained the initial symptoms that I was dealing with a device that had already hit the wall.

I don't see any options of in gparted or disk utility(red hat) for increasing the number of directory entries.

Funny thing though when I format using gparted the drive mounts read only. I have only been able to get it to be usable for writes using disk utility. Gparted does a better job of showing the progress and results associated with actions. I am not sure why I not getting a good result from the format.

All times are GMT -5. The time now is 10:40 PM.