LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problems with mouse and FB (Gentoo) (https://www.linuxquestions.org/questions/linux-newbie-8/problems-with-mouse-and-fb-gentoo-265607/)

Icetec 12-12-2004 01:37 PM

Problems with USB mouse in Gentoo
 
I installed Gentoo a while ago on my laptop (nx9105), and I have just one unresolved problem left.

I can't get my USB mouse to work properly. It lights up when I start Gentoo but I can't get it to work in X (or console for that matter). I had the same problem om my stationary computer, but it worked with a PS/2 mouse on it. Since I don't have any PS/2 ports on the laptop I have to get this resolved. The USB controller gets recognized properly. I heard that it might be because the mouse doesn't support USB 2.0, but since I don't have any products using 2.0 I can't see if that's true. Using "cat /dev/input/mice" does not do anything. No matter how much I move the mouse the command just hangs there until I cancel it.

I _REALLY_ need help here. I have tried to find a sollution to this problem for several days now, but noone seems to know.

Icetec 12-13-2004 01:19 AM

Please!? I can't be the only one having this problem!

David1nc 12-23-2004 06:28 PM

that's right, i have the same problem......

comprookie2000 12-23-2004 08:38 PM

post lsmod and your xorg.conf like this one,most likely don't have support enabled in the kernel;
Code:

Section "ServerLayout"
        Identifier    "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse1" "SendCoreEvents"
EndSection
# touchpad
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "PS/2"
        Option      "Device" "/dev/mouse"
        Option      "Emulate3Buttons"
        Option      "Emulate3Timeout" "50"
EndSection
# usb optical logitech mouseman with wheel
Section "InputDevice"
        Identifier      "Mouse1"
        Driver          "mouse"
        Option          "Protocol" "IMPS/2"
        Option          "Device" "/dev/input/mice"
        Option          "ZAxisMapping" "4 5"
EndSection

See if this helps; http://forums.gentoo.org/viewtopic.p...t=mouse+laptop
or http://forums.gentoo.org/viewtopic.p...asc&highlight=
and look for your laptop here;
http://www.linux-on-laptops.com/
and here for the kernel .config
http://gentoo-wiki.com/Gentoo_Acer_T...nual#USB-Mouse


All times are GMT -5. The time now is 06:13 AM.