LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-18-2003, 08:45 PM   #1
krystriana
LQ Newbie
 
Registered: Jan 2003
Location: Columbus Ohio
Distribution: Red hat 8
Posts: 6

Rep: Reputation: 0
Unhappy Problems with logging into GNOME


Hi,

I recently installed RedHat 8. I chose to install both the KDE and GNOME environments, and until tonight, never went into GNOME. When I enter GNOME, I receive the following message:

Could not look up INTERNET address for DHCPPC2. This will prevent GNOME from operating correctly. It may be possible to correct the problem by adding DHCPPC2 to the file /etc/hosts

Not sure what to add to /etc/hosts since my router on my network does DHCP.

Help!

Thanks,

-Krys
 
Old 01-18-2003, 09:08 PM   #2
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
Perhaps it wants the address of your router for DHCP? Try adding the following line to /etc/hosts:

<address of router> DHCPPC2
 
Old 01-18-2003, 09:37 PM   #3
c4_4ya
Member
 
Registered: Jan 2003
Location: Asheville, NC
Distribution: Slackware, RedHat
Posts: 35

Rep: Reputation: 15
Assuming that the name of your RH8 computer is DHCPPC2, you should add the entry to /etc/hosts (see oot's post). You must make sure that the entry is the same case (upper/lowercase) that you named your machine [avoid using mixed case names when dealing with hostnames and DNS, use all lowercase]. Make sure that you have an entry in /etc/sysconfig/network that looks like what you put in /etc/hosts:

NETWORKING=yes
HOSTNAME=DHCPPC2 (i would change this to dhcppc2!!)

Then I would modify your entry in /etc/hosts to reflect this new name. It would look like this:

127.0.0.1 dhcppc2 localhost.localdomain localhost

This entry would assign these 3 names to your machine, and point them to your loopback address (127.0.0.1).

Reboot afterwards and the errors should disappear.

Also, on DHCP enabled hosts, make sure that you never map any IP address to your computername in the /etc/hosts file, because if you get a different IP, you will be back to square 1.

If your RH 8 computername is something other than DHCPPC2, then respond and we'll go from there.

Last edited by c4_4ya; 01-18-2003 at 09:39 PM.
 
Old 01-19-2003, 08:27 PM   #4
krystriana
LQ Newbie
 
Registered: Jan 2003
Location: Columbus Ohio
Distribution: Red hat 8
Posts: 6

Original Poster
Rep: Reputation: 0
Lightbulb

Looks like that fixed my problem!!! Thanks c4_4ya and oot!!!

-Krys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.2 Pro, Problems Logging Into GNOME, Please Help sourav SUSE / openSUSE 1 01-31-2005 06:33 PM
logging out of gnome in xwin32 plythgam Linux - Software 0 01-11-2005 10:25 PM
Logging in from two different machines using GNOME vcrispo Linux - Networking 2 07-28-2004 02:33 PM
problem when logging out of gnome lamedavis Fedora 4 02-26-2004 02:53 PM
rh9 gnome problem after logging out spyghost Linux - Software 0 11-13-2003 07:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration