LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2010, 03:10 PM   #1
techiewannabe
LQ Newbie
 
Registered: Jul 2005
Posts: 27

Rep: Reputation: 0
Problems with Clamav


I am running Ubuntu's Jaunty and get the following messages when I try to Add/Remove any software:

E: clamav-base: subprocess post-installation script returned error exit status 1 E: clamav-freshclam: dependency problems - leaving unconfigured
E: clamav: dependency problems - leaving unconfigured
E: clamav-daemon: dependency problems - leaving unconfigured
E: clamtk: dependency problems - leaving unconfigured

I am a newbie and have no idea where to go with this. I've tried reinstalling Clamav...but no luck.

Can someone help me with this?

Thanks.

Techiewannabe
 
Old 01-17-2010, 07:47 AM   #2
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,087

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
How did you install it, thru Synaptic/apt-get or what?

Do sudo apt-get check in terminal
 
Old 01-18-2010, 11:29 AM   #3
Laurens73
Member
 
Registered: Aug 2009
Location: Zeewolde, Flevoland NL
Distribution: Debian squeeze (Gnome) on netbooks; Debian Lenny on servers and Debian wheezy (XFCE) on new laptops
Posts: 144

Rep: Reputation: 23
Sometimes the database gets corrupted with some files. If the option linus72 offered doesn't work, try the following in a terminal:

Code:
sudo dpkg --configure -a
If this doesn't help, try to reinstall it the hard way:

Code:
sudo apt-get remove clamav*
sudo apt-get install clamav*
If the last operation fails, what message do you get?
 
Old 01-18-2010, 04:52 PM   #4
techiewannabe
LQ Newbie
 
Registered: Jul 2005
Posts: 27

Original Poster
Rep: Reputation: 0
clam-av error message

Thanks to everyone for your suggestions. After scouting around on the Internet, I was able to remove some of the error messages. The only error message that I get now is:

E: Sub-process /usr/bin/dpkg returned an error code (1)

If anyone has any ideas about this, I'd appreciate your suggestions.

Thanks.

Tom
 
Old 01-22-2010, 08:23 AM   #5
Laurens73
Member
 
Registered: Aug 2009
Location: Zeewolde, Flevoland NL
Distribution: Debian squeeze (Gnome) on netbooks; Debian Lenny on servers and Debian wheezy (XFCE) on new laptops
Posts: 144

Rep: Reputation: 23
An other option is to remove the files containing this info in the dpkg database:

Code:
sudo rm /var/lib/dpkg/info/clamav*
and then reconfigure your package manager:

Code:
sudo dpkg --configure -a
Now your error message has to be gone. Clamav is installed, but not registered in the package manager after this action.
 
Old 01-23-2010, 02:10 PM   #6
techiewannabe
LQ Newbie
 
Registered: Jul 2005
Posts: 27

Original Poster
Rep: Reputation: 0
Thanks Laurens 73 for your suggestion.

Unfortunately, when I tried to follow the suggestions, I got the following message:

tom@Compaq:~$ sudo rm /var/lib/dpkg/info/clamav*
rm: cannot remove `/var/lib/dpkg/info/clamav*': No such file or directory
tom@Compaq:~$

Other ideas?

Thanks, again.

Tom
 
Old 01-24-2010, 02:35 PM   #7
techiewannabe
LQ Newbie
 
Registered: Jul 2005
Posts: 27

Original Poster
Rep: Reputation: 0
I did another uninstall and reinstall of Clamav and apparently, it has solved the problem. My thanks to all of you who offered suggestions!

Tom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
file-scan-clamav-1.8 or clamav-0.93.1 invader44 Linux - Newbie 1 12-29-2009 08:49 AM
question about SLACKBUILD: clamav and problems with milter ragebot Slackware 13 08-21-2008 03:36 PM
ClamAV Update Problems carlosinfl Linux - Server 9 04-15-2008 09:09 PM
Installing ClamAV from source on Debian x86_64 - problems Malibyte Debian 2 06-28-2005 01:22 AM
problems with clamav AVD_ZM Linux - Security 0 02-13-2005 07:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration