LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problems using yum to install any application (https://www.linuxquestions.org/questions/linux-newbie-8/problems-using-yum-to-install-any-application-711133/)

Muideen 03-12-2009 02:56 PM

Problems using yum to install any application
 
Hi, I am just installed fedora 9, my first linux experience. I am having problems while trying to use yum to install applications, each time i typed the necessary command I get this error 'Another app is currently holding the yum lock; waiting for it to exit...' eventhoug i am very sure there is no other application or installation going on. I have tried it several times, even restarting the computer on numerous occassions, but i still get the error and it does not ever seem ready to stop.

reddazz 03-12-2009 03:18 PM

Hi and welcome to the forum.

Your problem could be as a result of the yum update service. Before using yum, try to disable the updates service by doing
Code:

service yum-updatesd stop
If you prefer checking for updates by yourself, you can disable the service permanently by doing
Code:

chkconfig yum-updatesd off

Muideen 03-12-2009 03:49 PM

thanks reddazz, i have tried running that code (service yum-updatesd stop) from the terminal, but it gives me this

[Parkway@localhost ~]$ service yum-updatesd stop
bash: service: command not found
[Parkway@localhost ~]$ su
Password:
[root@localhost Parkway]# service yum-updatesd stop
bash: service: command not found
[root@localhost Parkway]#

x_terminat_or_3 03-12-2009 05:08 PM

Hi Muideen

You have almost got it right.

What happens when you do su is that it will give you root privileges, but it does not set the search paths, so it still cannot find the `service' script.

To fix this, instead of doing su, try

Code:

su -
This will make it a login shell. So after you have typed in your password, try the service command listed above again.

Lee_Ball 03-12-2009 05:19 PM

I always do an su -l, its just habit now.

x_terminat_or_3 03-12-2009 05:33 PM

the `service' script comes from the initscripts package. If it is not installed then it would be normal that the service script is not available.

To confirm this, please try (as root)

Code:

/sbin/service yum-updatesd stop
Also, temporary, at least, so you can proceed with YUM this time, kill all processes that might hold a lock

Code:

ps xua | grep -i yum | grep -v grep | awk '{print $2}' | xargs kill -9
If it tells you something like:

Quote:

usage: kill [ -s signal | -p ] [ -a ] pid ...
kill -l [ signal ]
It just means that it didn't find any processes with yum in their name.

Muideen 03-13-2009 04:09 AM

Thanks a lot guys,I have tried all the scripts you gave me, and it is still not working. Seems like yum or the service scripts is not even installed. This is what i got.


[Parkway@localhost ~]$ su -
Password:
[root@localhost ~]# service yum-updatesd stop
yum-updatesd: unrecognized service
[root@localhost ~]# /sbin/service yum-updatesd stop
yum-updatesd: unrecognized service
[root@localhost ~]# ps xua | grep -i yum | grep -v grep | awk '{print $2}' | xargs kill -9
[root@localhost ~]#



Someone should please help with this

x_terminat_or_3 03-13-2009 04:15 AM

The kill command apparently succeeded, therefore, you should try doing your yum install again.

Muideen 03-13-2009 05:07 AM

Thanks a lot guys,I have tried this to unlock all processes holding lock since the error reported was that some processes were holding locks.

[Parkway@localhost ~]$ su -
Password:
[root@localhost ~]# ps xua | grep -i yum | grep -v grep | awk '{print $2}' | xargs kill -9

After which i run the following code to install php, mysql, and Apache on my machine.

yum -y install httpd php mysql mysql-server php-mysql

And fortunately for me, it is now working fine as it is presently downloading and installing the apps.

But if there is any problem I will not hesitate to let you guys know.

Thanks a million

Lee_Ball 03-13-2009 05:47 AM

I'm quite confused with all this difficultly closing the file holding the lock. When I use yum it always tells me which PID is doing it. I then just close that off if I can't wait.

Muideen 03-13-2009 03:03 PM

please can someone help me with the code to change the root password for mysql as i mistakenly set it to a wrong value during set up

x_terminat_or_3 03-13-2009 03:06 PM

Hi Muideen

Please open a new thread for this question.


All times are GMT -5. The time now is 03:18 PM.