LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2017, 01:02 PM   #16
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841

Quote:
Originally Posted by clifftec View Post
ok... this was cool. I found some code on the net, and when I pasted the whole lot in..... my wireless suddenly appeared and is now fully working as I type.... solvered!

here is that code:

sudo mkdir /lib/firmware/b43
sudo cp Desktop/b43/* /lib/firmware/b43
sudo rmmod -f b43
sudo rmmod -f ssb
sudo modprobe b43
Hi...

Awesome, glad you got it working! I'd be curious to know the answer to Shadow_7's question, too.

Regards...
 
Old 06-26-2017, 05:40 PM   #17
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
ah... thankyou shadow7, I dare say I have inadvertently used b43-fwcutter without realizing in my scurry to fix this issue... now the downside here is after rebooting, the wireless network wlan disappeared again, just leaving the Ethernet available. I opened terminal again, re-pasted the code and ... wallah... wireless. How does one make sure the session and its changes are embedded for next boot? I have strolled around the standard access of settings etc, though haven't been able to save them.
 
Old 06-26-2017, 05:47 PM   #18
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
... thanks again ardvark71, yes I am also a little curious as to the mend... by the way, it's happy wave day in aus... so... a huge wave to you all.!.!.!
 
Old 06-27-2017, 01:54 PM   #19
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by clifftec View Post
... thanks again ardvark71, yes I am also a little curious as to the mend... by the way, it's happy wave day in aus... so... a huge wave to you all.!.!.!
You're welcome, a big wave to you, too!

Just out of curiosity, the next time you boot into PCLinuxOS, before doing anything else, navigate to "/lib/firmware/b43" using your file manager (whatever that is for your version of PCLinuxOS) and see if this folder exists in that location. If so, is the firmware file inside of it? Please let us know.

If you're using the KDE Desktop environment, the file manager might be called "Dolphin."

Regards...
 
Old 06-27-2017, 04:43 PM   #20
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
In terms of custom kernel modules, every time the kernel updates, they go away. Otherwise I'm not sure why your thing is changing at reboot unless something is funky like read-only or a ram based distro like puppy. You might try removing the udev auto detected stuff and rebooting, one trick to get eth0 again when moving sticks across several machines.

$ sudo rm /etc/udev/rules.d/70-persistent-net.rules
$ sudo shutdown -r now

The firmware should remain, as long as you were root when you copied it to the firmware location. Just remember that you need new firmware when you do a fresh install. One other possibility is that you have the wifi module blacklisted in /etc/modprobe.d/ so you have to manually load it after booting.

$ egrep -r -i blacklist /etc/modprobe.d/* | grep -i b43

Also the b43 driver is odd since there's a b43-legacy variant. Most things should use the b43 driver though, the legacy one is REALLY REALLY legacy, AKA OLD. And the 4318 isn't "that" old.
 
Old 06-27-2017, 07:52 PM   #21
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
there is a b43 folder with a load of files, and an empty b43 legacy folder. Not sure what I was looking for in the blacklist files, nothing looks familiar with any file-names, here's the list in-case my other post didn't pop up

blacklist snd-usb-audio
blacklist snd_pcm_oss
blacklist snd_mixer_oss
blacklist snd_seq_oss
blacklist pata_acpi
blacklist rivatv
blacklist i82875p_edac
blacklist usbkbd
blacklist usbmouse
blacklist pcspkr
blacklist snd-pcsp
blacklist ssb
blacklist ssb
 
Old 06-27-2017, 07:55 PM   #22
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
the blacklist comp folder has this


# watchdog drivers
blacklist i8xx_tco

# framebuffer drivers
blacklist aty128fb
blacklist atyfb
blacklist radeonfb
blacklist i810fb
blacklist cirrusfb
blacklist intelfb
blacklist kyrofb
blacklist i2c-matroxfb
blacklist hgafb
blacklist nvidiafb
blacklist rivafb
blacklist savagefb
blacklist sstfb
blacklist neofb
blacklist tridentfb
blacklist tdfxfb
blacklist virgefb
blacklist vga16fb
blacklist viafb
blacklist matroxfb_base

# ISDN - see bugs 154799, 159068
blacklist hisax
blacklist hisax_fcpcipnp
 
Old 06-27-2017, 10:32 PM   #23
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
observation:

upon startup I have wlan and an ethernet in the network centre window.
try to start wlan commection... connection failure.
open terminal issue commands - 'rmmod -f b43' and then 'modprobe b43'
try the wireless connection again and I have a successful connection.

restart after saving session and I get a connection failure again until I do the two commands in terminal window.
 
Old 06-28-2017, 04:40 AM   #24
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
You might try:

$ sudo ifconfig wlan0 up

Before trying to use the interface. That should "load" the module and such. Also "modprobe -r" is the modern way of rmmod. When you have a quirky driver you'll need to unload and reload to regain device usability again. Finding / using different firmware can help with some hardware.

https://downloads.openwrt.org/sources/

For an old dell I have I have to use b43-fwcutter on:
broadcom-wl-4.150.10.5.tar.bz2

Where the distro grabs:
broadcom-wl-5.100.138.tar.bz2

by default when you install b43-fwcutter. Also in that case the fwcutter from debian wheezy and with the --unsupported flag to get the firmware. Which seems to be missing from the version that ships with jessie. Hopefully I'll get around to a stretch install soon. Most likely quirky drivers will always be quirky, so a dongle or ddwrt client_bridge setup might be a better option since you can join the N and AC generation of connection speeds. I like doing the bridge route since wifi can be quite a resource hog on low spec'd computers. Plus when the lease renews or other interruptions happen, you get more of a latency effect on your local machine, instead of a disconnect effect.
 
1 members found this post helpful.
Old 06-28-2017, 06:49 AM   #25
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
well you're certainly right about the 'quirky' drivers, hit and miss that's for sure. Ok... maybe this could throw a light on the issue. After numerous re-starts and log off/ons, in both root and user modes, I have broken the commands to one that lets me connect every time... rmmod -f b43. That's all I have to enter into the terminal.

I know when it won't connect (when the network name is highlighted when I open the Network Centre) as opposed to after running rmmod -f b43 in the terminal, then the NC opens without any highlighted network, and when I select mine... it connects fine.
 
Old 06-28-2017, 05:58 PM   #26
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
seems like when I run the rmmod command and then open NCenter, it gives me a fresh choice of available networks. Is there some code I could use to make it carry out this function each start, I know that would be a workaround, though that seemed to let wlan work every time. At least the puter boots wlan-up now.
 
Old 07-14-2017, 07:44 PM   #27
clifftec
Member
 
Registered: Jun 2017
Location: Gold Coast, Queensland, Australia
Distribution: LinuxLite
Posts: 53

Original Poster
Rep: Reputation: Disabled
... naaa, I am going to do a full re-install of the latest PcLos, it works fine on my other machine, thanks all for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with drivers and ndiswrapper Zany.exe Linux - Laptop and Netbook 1 05-24-2009 05:39 AM
problem with ndiswrapper in PCLOS newbiesforever Linux - Distributions 10 07-31-2007 05:20 PM
ndiswrapper install problems emu103 Linux - Wireless Networking 3 05-04-2007 10:35 AM
Problems Installing wpasupplicant with ndiswrapper Drivers tom_w Linux - Wireless Networking 6 07-27-2006 11:41 AM
ndiswrapper install problems drum2jc Linux - Software 2 01-04-2005 12:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration