-   Linux - Newbie (
-   -   Problems setting time and time zone in RH Linux (

am_mitra 12-02-2008 05:12 AM

Problems setting time and time zone in RH Linux

I am on redhat linux advanced server 4.

I am in Time-zone "Asia/Calcutta", and that is what I am trying to set my timezone to. I have tried everything that google-search provided, but nothing is working for some reason.

Right now, the 'date' shows: Tue Dec 2 16:30:02 UTC 2008

ie. timezone=UTC. Whereas I expected it to be IST (Indian Standard Time).

So, I tried tzselect -> Asia ->India and I agreed to:

Local time is now: Tue Dec 2 16:31:05 /usr/share/zoneinfo/Asia/Calcutta 2008.
Universal Time is now: Tue Dec 2 16:31:05 UTC 2008.

I do not know why "Universal Time" is showing as the localtime.

The 'date' command again gave: Tue Dec 2 16:31:43 UTC 2008

Second, I ran dateconfig command, and set it to Asia/Calcutta and UTC off, but still the same result.

My /etc/sysconfig/clock file:
[root@ps2844 ~]# cat /etc/sysconfig/clock

I also setup a sym-link from /usr/share/zoneinfo, and yet no result.

[root@ps2844 ~]# ls -l /etc/localtime
lrwxrwxrwx 1 root root 33 Dec 2 10:16 /etc/localtime -> /usr/share/zoneinfo/Asia/Calcutta

[root@ps2844 ~]# date
Tue Dec 2 16:39:50 UTC 2008

Let me know what else can I try to move this to the correct timezone.

tuxtutor 12-03-2008 08:09 PM

Stupid question but did you reboot after changing the time zone info? I think that is a requirement. Not positive though I just remember needing to reboot when I altered my timezone settings.

All times are GMT -5. The time now is 10:36 AM.