LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2014, 01:29 PM   #1
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Rep: Reputation: Disabled
Problems running sumo (libxerces-c.so.27: cannot open shared object file)


hello all, i installed sumo 0.12.3 in fedora 12 . while type command in terminal it gives me error like :

]sumo: error while loading shared libraries: libxerces-c.so.27: cannot open shared object file: No such file or directory

i am confused,please its greatful to sharing your experience .

Thank you
 
Old 01-22-2014, 05:56 AM   #2
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 327

Rep: Reputation: 73
do a "ls -la /usr/lib/libxerc*" (or "ls -la /usr/lib64/libxerc*" if you have a 64-bit host), if you have no results, install package libxerces-c, otherwise do a symlink to the existing version of the library
 
1 members found this post helpful.
Old 01-22-2014, 06:28 AM   #3
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
hello sir,i installed sumo in fedora but i tying sumo-gui then i got following error message.
sumo: error while loading shared libraries: libxerces-c.so.27: cannot open shared object file: No such file or directory
kindly requst to solve out this error . Thank you
 
Old 01-22-2014, 06:31 AM   #4
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 327

Rep: Reputation: 73
it seems you're missing a library dependency, libxerces; (re)install that package
 
1 members found this post helpful.
Old 01-22-2014, 06:33 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,737

Rep: Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318
Quote:
libxerces-c.so.27: cannot open shared object file: No such file or directory
Solution :

# yum install xerces-c27
http://archives.fedoraproject.org/pu...6/os/Packages/

-
 
1 members found this post helpful.
Old 01-22-2014, 06:55 AM   #6
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
first of all thank so much....
i am trying to solve my problem as per your guidance .
 
Old 01-22-2014, 07:11 AM   #7
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
hello sir
i type # yum install xerces-c27 and process is start ,, it will installd all packages or going with as per you link and download rpm file ,, m bit confused!!!
 
Old 01-22-2014, 07:40 AM   #8
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
hello knudfl
i installed xerxes c27 ,, then after what i do ? given your link there is three rpm realated xerces c27 files which i download ? please help
regards
 
Old 01-22-2014, 08:04 AM   #9
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
hello kundfl ,
i thank u so much ,,bt i typed sumo -gui then it gives me folllowing error how i deal with it ?

[root@fedora sumo-0.12.3]# sumo -gui
Error: On processing option '-gui':
No option with the name 'g' exists.
Error: Could not parse commandline options.
Quitting (on error).
 
Old 01-22-2014, 08:07 AM   #10
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 327

Rep: Reputation: 73
i don't know sumo, but i wuold try "sumo-gui" or "sumo --gui", even try "sumo" to see if dependecies troubles are solved
 
1 members found this post helpful.
Old 01-22-2014, 08:18 AM   #11
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
thank you gengisdave
 
Old 01-22-2014, 10:47 AM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,737

Rep: Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318
# 9 .

# sumo -gui : Wrong !

First : Do not run the sumo commands as root.

Did you forget to read the "sumo threads" ? →
→ → http://www.linuxquestions.org/questions/tags/sumo/
#12, the 11 executable http://www.linuxquestions.org/questi...4175491669/#12

I.e. the command is not 'sumo -gui', but $ sumo-gui

-
 
Old 01-23-2014, 06:11 AM   #13
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
Hello all,i installed sumo and move bt,i hv problem to install ns ,, i set set path and type ns it gives me following error :
[root@fedora ns-allinone-2.34]# ns
bash: ns: command not found so what i hv 2 do its great to share with your experience.
 
Old 01-23-2014, 08:02 AM   #14
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,737

Rep: Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318
# 13 .
Quote:
[root@fedora ns-allinone-2.34]# ns
No root commands, please. ( Unless you are looking for troubles.)

The setup should be /home/silinux/ns-allinone-2.34/
.. and all command are to be done as unprivileged user.
( Except "make install" ).

How to get the executable 'ns' in a system PATH : Very simple :
$ cd ns-allinone-2.34/ns-2.34/
$ su
# make install
.. I.e. 'make install' will copy ns to /usr/local/bin/ns : A system PATH.

-
 
1 members found this post helpful.
Old 01-23-2014, 08:13 AM   #15
silinux
LQ Newbie
 
Registered: Jan 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
thank you so much sir ,, i installed ns and gets % sign ,, and now i typed nam it gives me error : [root@fedora ns-allinone-2.34]# nam
bash: nam: command not found ,, so how i deal with it !!!

Last edited by silinux; 01-23-2014 at 08:15 AM.
 
  


Reply

Tags
ns2, sumo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error while loading shared libraries: libexpat.so.0: cannot open shared object file: Naimbora Linux - General 2 08-02-2013 02:53 PM
error while loading shared libraries: libcrypt.so.1: cannot open shared object file: xmixail Linux - Kernel 15 07-29-2012 09:39 PM
error while loading shared libraries: libstdc++.so.5: cannot open shared object file: Franziss Linux - Newbie 10 06-28-2010 06:47 AM
error while loading shared libraries: libhid.so.0: cannot open shared object file: No misungs Linux - Software 4 06-10-2009 01:05 PM
error while loading shared libraries: libdb-4.1.so: cannot open shared object file putquery8581 Linux - Software 1 10-01-2004 08:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration