LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-23-2010, 09:43 AM   #1
smitakamdar
LQ Newbie
 
Registered: Oct 2010
Posts: 9

Rep: Reputation: 0
Smile Problems Installing ZPygresqlDA on RedHat LInux


Hi,

I have installed the following products on LINUX RedHat :
1) Zope-2.6.2
2) python-2.1.3
3) Openflow-engine-1.1.0
4) postgresql-7.4.13
5) Egenix-2.0.6

Now I am in the process of installing ZPygresqlDA-0.0.3 to connect zope & postgresql & for its (ZPygresqlDA-0.0.3) installation I followed the below steps Ė

1)I downloaded & untared ZPygresqlDA-0.0.3 in zopeís Products dir i.e. (lib/python/Products)

2)I added the below line to Setup file in ZPygresqlDA/src directory Ė

-----------------------------------------------------------------------------------------------------------------------------------------------------



*shared*

_pg pgmodule.c -I/home/test/Python/2.1.3/lib/python2.1
-I/usr/local/pgsql/include
-I/usr/local/pgsql/include/server
-L/usr/local/pgsql/lib -lpq Ėlcrypt



------------------------------------------------------------------------------------------------------------------------------------------------------

Where python is installed at /home/test/Python/2.1.3
Postgresql is installed at /usr/local/pgsql
Zope is installed at /opt/zope

3)I copied pg.py to /home/test/Python/2.1.3/lib/python2.1

4)make -f Makefile.pre.in boot

5)make & make install

Upto 4th step it worked fine. But in the 5th step (i.e. make & make install) it shows the below error Ė
-------------------------------------------------------------------------------------------------------------------------------------------------------------------

gcc -fPIC -g -O2 -Wall -Wstrict-prototypes -I/home/test/Python/2.1.3/include/python2.1 -I/home/test/Python/2.1.3/include/python2.1 -DHAVE_CONFIG_H -I/home/test/Python/2.1.3/lib/python2.1 -I/usr/local/pgsql/include -I/usr/local/pgsql/include/server -c ././pgmodule.c -o ./pgmodule.o

././pgmodule.c: In function ‚pgconnect‚:

././pgmodule.c:694: warning: passing argument 4of ‚PyArg_ParseTupleAndKeywords‚ from incompatible pointer type

/home/test/Python/2.1.3/include/python2.1/modsupport.h:14: note: expected ‚char **‚ but argument is of type ‚const char **‚

././pgmodule.c:2128:5: warning: missing terminating " character

././pgmodule.c: In function ‚pgsetdefpasswd‚:

././pgmodule.c:2128: error: missing terminating " character

././pgmodule.c:2129: error: ‚None‚ undeclared (first use in this function)

././pgmodule.c:2129: error: (Each undeclared identifier is reported only once

././pgmodule.c:2129: error: for each function it appears in.)

././pgmodule.c:2129:7: warning: missing terminating " character

././pgmodule.c:2129: error: missing terminating " character

././pgmodule.c:2130: error: expected identifier before ‚return‚

make: *** [pgmodule.o] Error 1

------------------------------------------------------------------------------------------------------------------------------------------------------------------

I am not able to solve this. Am I missing any step?? Please help.

Thanks & Regards,
Smita Kamdar
 
Old 12-23-2010, 01:45 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I'd say try to find something that's actually supported on your
platform. You're trying to fit square pegs in round holes.

All the software you're installing has been out of support (or
not updated) in over 4 years. The latest supported version of
Postgres 7.4 is 7.4.30. That means that you're missing at
LEAST 17 security/bug fixes, not to speak of performance
improvements that have been introduced since.
 
Old 12-29-2010, 10:21 AM   #3
smitakamdar
LQ Newbie
 
Registered: Oct 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Hi,

I know that the versions of softwares that I have installed are very old & out of support. But I compulsarily need to use these versions as I need to set up a dev env exactly matching the live env. & the live env is already set up with these installables. I am under compulsion to do this. Can anyone please try to give me a solution to this error? Please i am in urgent need of help. Please someone help me.
 
Old 12-29-2010, 11:51 AM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Have you considered cloning the install, and just changing the hostname & ip address?
 
Old 12-30-2010, 05:05 AM   #5
smitakamdar
LQ Newbie
 
Registered: Oct 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Do U mean cloning ZPygresqlDA of live box? How do we do that?

Thanks for your response.
 
Old 12-30-2010, 12:00 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I meant cloning the box
 
Old 01-03-2011, 02:04 AM   #7
smitakamdar
LQ Newbie
 
Registered: Oct 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Problem Installing ZPygresqlDA on RedHat LInux

How do we clone the box? I dont have any idea how do we do that. Can you please suggest something?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems witn Installing Nagios on RedHat Linux 4,0 wlchak Linux - Software 7 01-24-2013 06:16 AM
Problems installing RedHat Database 2.1 on Redhat Linux 9 bkimelman Linux - Software 0 10-18-2003 02:32 PM
problems with installing linux redhat pawan sharma Linux - General 2 10-04-2003 07:11 PM
problems with installing linux redhat 7.1 udayan Linux - Software 0 09-30-2002 06:39 AM
Hi, new to this Linux thing...problems installing RedHat 7.3 EvilFranky Linux - Software 3 08-11-2002 02:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration