LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problems installing Mozilla 1.2b with XFT (https://www.linuxquestions.org/questions/linux-newbie-8/problems-installing-mozilla-1-2b-with-xft-34939/)

AldebaranDanu 11-08-2002 09:56 PM

Problems installing Mozilla 1.2b with XFT
 
Ok. I just formatted and re-installed Red Hat 8.0.

I went to ftp.mozilla.org, and went to the folder for 1.2b. There were two folders, SRPMS, and i386. I downloaded the rpm in the i386 folder, but I was told that I needed to install some other packages. So, I tried the one in the SRPMS folder, and it prompted me to insert my CD, and it installed the afore mentioned packages.

So, after figuring out that the one in the SRPMS folder was the source, I decided to try the other one again.

Lo and behold, it didn't tell me that I needed to install those other packages... but now, it says that the package "mozilla" is already installed.

Here's what I've tried so far:

1) I found a post on these forums that said in order to uninstall mozilla you have to do this (in order to find out all the packages to uninstall):
rpm -qa| grep -i mozilla
And then this:
rpm -e *each package listed from the above*

I used the first command, and got a nice little list of packages that Mozilla uses. But as soon as I try to "rpm -e" one of them I get "error: failed dependencies:"


2) In the Red Hat Menu (equivalent to Windows Start Menu), I went to "System Settings" > "Packages". Then browsed to Mozilla, deselected it, and chose Update. Linux then says it needs to figure out package dependencies. But it just seems to hang there. The little progress bar never goes.

What can I do to get Mozilla 1.2b with XFT support installed?

Thank you,
AldebaranDanu

Slasher 11-10-2002 09:42 AM

One easy way to get mozilla 1.2b with XFT support, is to download the source (tar.gz), and compile it with support for XFT.


All times are GMT -5. The time now is 10:59 AM.