LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problems installing Apache 2.0.49, PHP 4.3.6, and GD 2.0.22 (https://www.linuxquestions.org/questions/linux-newbie-8/problems-installing-apache-2-0-49-php-4-3-6-and-gd-2-0-22-a-172249/)

Thorin98 04-19-2004 07:51 PM

Problems installing Apache 2.0.49, PHP 4.3.6, and GD 2.0.22
 
I'm a Linux newbie, running Red Hat 9.0. I've currently got Apache 2.0.40, PHP 4.2.2 and GD 1.6.2. My aim is to upgrade to GD 2, as I'm using Coppermine gallery, and want better quality resized images in it.

I read various things and decided it would be easiest to update PHP to the latest version (4.3.6) as it includes a version of GD 2. I can't remember what phase of the install I got to, but it told me that I needed a newer version of Apache 2. I then attempted to install apache 2.0.49 from source code. This appeared to have been completed successfully, but Apache 2.0.40 still seems to be running, and I can't find the new version (I'd stopped httpd before I installed the new version, and then started it again after the installation). I then tried a different tack again, and tried to install GD 2.0.22. This appeared to complete successfully, but I can't use GD 2 commands, and phpinfo() tells me I still have 1.6.2.

I think I now have two options available:

Get GD 2.0.22 working, I think I need to rebuild PHP to use it, although I'm not sure if I'm right about that, or how to go about it.

Properly install Apache 2.0.49 and then php 4.3.6.

Basically I've just gotten into a bit of a muddle with this. I don't think I've ever managed to successfully install anything by doing a ./configure, make, make install in linux before, I always seem to encounter problems of some sort, so I'm still very much a linux newbie! Any help would be greatly appreciated.

j-ray 04-20-2004 03:13 AM

but Apache 2.0.40 still seems to be running...

u can install several versions of apache but if u start the old one - the old one will be running ;-).
what i want to ask is: maybe simply the wrong start command?


All times are GMT -5. The time now is 07:37 PM.