LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   problems accesing win2k after mandrake installation (https://www.linuxquestions.org/questions/linux-newbie-8/problems-accesing-win2k-after-mandrake-installation-46681/)

joemamma 02-22-2003 03:18 PM

problems accesing win2k after mandrake installation
 
so before i installed mandrake i had 2 os'es on my computer, win2k and winxp...i wanted to do a triple boot so i set up lilo to detect both microsoft systems...after installation i have no problems accessing mandrake and winxp but now i have problems booting into win2k

here is my setup..i have win2k on my c: drive and winxp is on a second hard drive on like partition j: or osmething....the open space i had available was on my first hard drive and so i installed mandrake into the e: drive

i now my config sounds unorganized but that's cos i never planned to have all these os'es on my computer

anyways after installing mandrake and when i try to log into win2k it tells me that it has problems accessing the mandrake partition and performs a check disk that fails and asks me if i want to proceed...i choose to and win2k logs on but after it shows the box saying preparing network connections nothing happens...i just see a default blue background screen and nothing loads....

any ideas on what's going on?

joemamma 02-22-2003 03:19 PM

Re: problems accesing win2k after mandrake installation
 
.

MasterC 02-22-2003 03:54 PM

Might be a boot loader problem (probably rather than might ;) ) You can boot up with the Mandrake install CD and get to the point where you press Enter to continue or F1 for more options. Press F1 and type rescue. Then when you get to the menu, choose to restore the win boot loader. At that point, make sure you have a Mandrake boot floppy.

From there, I suggest looking into using the win boot loader to boot all of your OS's. There are alot of threads around here on doing that, so I will leave that up to you to search for ;)

Cool

joemamma 02-22-2003 04:03 PM

so when i repair the mbr it will know to go back to the dual boot with win2k and winxp?

MasterC 02-22-2003 04:04 PM

It will return the MBR to the state it was in prior to installing Mandrake. So assuming that was setup fine before, it should be setup correctly after doing the restore.

Cool

joemamma 02-22-2003 04:17 PM

great! it worked, thanks a lot!

so now i can boot linux from a floppy and win2k/winxp from the original mbr BUT win2k still doesn't boot up :confused:

once the splash screen is done loading i get the black screen indicating that win2k can't read the linux partition...for some reason win2k thinks that it is still a fat32 partition....do you know hwo to resolve this?

MasterC 02-22-2003 04:32 PM

Not too sure. If you have a w2k boot floppy/rescue disk, I'd try booting up with that and seeing if it states something specific. Although having linux on your machine is causing the problem, it's a win problem. I don't have alot of experience with running w2k so I really wouldn't even know where to start. Maybe try booting up into fail-safe mode, and see if there is something going on with the drive mappings?

Good Luck

Cool

Allen614 02-22-2003 07:25 PM

I think your problem may be that Mandrake is installed on a logical instead of a primary partition. You can have up to 4 primaries per disk.


All times are GMT -5. The time now is 08:38 AM.