-   Linux - Newbie (
-   -   Problem with USB floppy drive (

j_l_ajaste 06-24-2003 09:52 AM

Problem with USB floppy drive
Hello friends, a question from a total Linux novice.

I have just installed RH 8.0 (kernel version 2.4.18-14) in a dual boot setup with XP, using GRUB, on a Compaq Presario notebook. In order to proceed with the RH 8.0 install, I had to type "linux nofirewire noprobe nopcmcia" at the start of the installation, or else the installation would hang at (various) places. With "linux nofirewire noprobe nopcmcia," the installation proceeds seemingly smoothly.

Later, at the GRUB screen when I am logging on, I find that I also need to hit "a" and add the "nousb" kernel argument, or else the Linux boot will hang at "Initializing firewire controller (ohci1394)". With "nousb," I get "[OK]" at the "Initializing firewire controller (ohci1394)" line in the boot sequence, and proceed into RH without difficulty. However, of course my USB floppy drive is now unavailable! Does anyone know how I can at this point mount my USB floppy drive?? When I right-click on the RH screen and go to "disks," only the CDROM appears.

Any assistance anyone can give with this problem will be gratefully acknowledged.

Jared :rolleyes:

cropcircle 06-28-2003 06:26 PM

First, try getting Linux started as usual :

- Log in as root.
- Insert your USB floppy device.
- Type "dmesg".

at the bottom, do you see something like? :

Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: Model: Rev:
Type: Direct-Access ANSI SCSI revision: 02
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
USB Mass Storage support registered.

If so, make a mountpoint where we try to mount the usb device, like this : "mkdir /mnt/usb".

Then do "cdrecord --scanbus" (USB access in Linux 2.4 goes currently with a SCSI emulation subsystem).

Finally, try to mount the USB device with : "mount -t auto /dev/sda1 /mnt/usb/"

If you're having troubles, check if the proper modules are loaded :

"lsmod |grep -i usb"

(Check for "usb-storage", if this one isn't loaded do "modprobe usb-storage").

Good luck.

j_l_ajaste 06-28-2003 09:16 PM

Thank you. I will try your recommendations and will post a reply.


j_l_ajaste 06-29-2003 03:39 PM


Upon typing "dmesg" I saw exactly the lines you wrote above. I then created the mount point using "mkdir," then did the "cdrecord --scanbus." When I used the mount command as you state above, I get a message saying that "/dev/sda1 is not a valid block device." I then did "lsmod |grep -i usb" and usb-storage came up ok. But I still get the "/dev/sda1 is not a valid block device" error.

thx/ Jared

cropcircle 06-30-2003 03:09 PM

Can you post the output of the command "cdrecord --scanbus"?

j_l_ajaste 06-30-2003 08:01 PM

Cropcircle... through trial and error, using what you outlined above, I was able to mount the USB floppy drive by changing "sda1" to "sda." Not certain why that made a difference, but it did! I don't have the notebook here so unfortunately I can't post the output of "cdrecord --scanbus," but the output from that command did not look abnormal.

However, I notice that I still cannot mount (or unmount) the USB floppy via the GUI (i.e. by right clicking on the RH 8 Gnome desktop and going to "disk" ...only the CDROM appears on the menu.) Is it possible to modify RH 8 so that mounting and unmounting of the USB drive can be done this way? How do I get the drive to appear on that GUI menu every time I log on?

Thanks again for all your help.


cropcircle 07-05-2003 02:55 PM

First, the bad news :

The fact that you cannot use the GUI Disks menu for this after plugging in a USB floppy, is because of this is a known bug in the current version of Gnome :

It will be probably fixed in the next version of Gnome.

And now the good news :

You can make mounting that drive a little easier by modifying the "/etc/fstab" file (you might want to backup this file, before you edit in it).

For example, for my USB memory stick, I've put in the following line at the end of the file :

/dev/sda1 /mnt/usb auto defaults 0 0

Now, if I want to mount my USB memory stick, I'll only have to do the command "mount /mnt/usb".

j_l_ajaste 07-05-2003 05:01 PM

Interestingly enough, when I added:

"/dev/sda /mnt/usb auto noauto,owner,user 0 0 "

to fstab, the desks menu on the desktop showed "usb" as a mountable option! However, when I take "user" out of the line above, the menu item disappears.

Thanks again for your assistance.


cropcircle 07-06-2003 05:57 PM

Glad to hear it worked out alright.

ps. The fact that in your case it needs the 'user' option has probably to do with rights. According to the manpage of fstab this option allows a non-root user to mount the device.

aru_titi 07-10-2003 12:38 PM

Cropcircle solutios its right!!! I have purchased the StarMagic MP3 player that can storage 128Mb (usb connection) & i had no idea how to use with RH9, and this was the final solution.


All times are GMT -5. The time now is 10:54 PM.