LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem with updating kernal, Cannot find initial console (https://www.linuxquestions.org/questions/linux-newbie-8/problem-with-updating-kernal-cannot-find-initial-console-164784/)

Dole-by 03-31-2004 10:02 PM

Problem with updating kernal, Cannot find initial console
 
I recently decided to dual boot linux and windows. I decided to try various live-cds to find out which one would work with my system the best.

Most of the live cds did not work very well with alot of things.

So I found one, everything but the USB worked. That was do-able I Installed it and got the USB working.

So first off I killed all services I wasn't using or going to use anytime soon like httpd. The httpd ran at startup removed it.

I installed red carpet and updated everything but the kernal. Reboot everything works fine.

Changed all the passwords customized my system, set up security and changed options to make more secure.

Note, I can boot up into my old kernal just fine from the boot screen I backed it up to a different folder and when I select that option I boot up (which is what I'm in currently typing this up everything works fine)

I backed up my current /boot/ directory to /boot2/ and set lilo to boot my current kernal from there.

I then updated the kernal and ran /sbin/lilo

Rebooted in the new kernal got "unable to open initial console" after the mem free message.

So rebooted into the old kernal, works fine.

I installed the new kernal using rpm -ivh kernel-2.4.22-1.2174.nptl.i686.rpm.

The cd I used was the adios live-cd, I installed it (the install automatically used a ntfs to ext3 partition thing, I couldn't avoid it so I reformated it into ntfs otherwise wouldn't work)

It's based off red hat 9 and all the software and everything I have done has been based off that.

I was thinking that it might be because of some way the live-cd has things set up.

I could download and install red hat since it seems to work with my computer, but I have already spent alot of time setting everything up and I rather like the startup screen it uses allowing me to change interfaces at a whim.


I was wondering if anyone has heard of this problem and can provide me with a way to fix it. If it takes more time than I spent setting it up (about 10 hours), then I will just install red hat from scratch.

Thanx ahead of time.

maddoug 04-08-2004 11:56 AM

Just a thought - is the line root=/dev/hdxx in your lilo.conf pointing to the right partition?

I had the same error message and fixing that line solved my problem.


All times are GMT -5. The time now is 10:55 AM.