LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem with the evolution mail program (https://www.linuxquestions.org/questions/linux-newbie-8/problem-with-the-evolution-mail-program-229627/)

stab 09-12-2004 07:15 AM

Problem with the evolution mail program
 
Hello,

Yesterday i set up evolution and it was working properly.
Then I turned off the computer and turned it on today and now
I got this error message while evolution is loading :

Code:

Could not start component
OAFIID:GNOME_Evolution_Mail_ShellComponent
Activation system error is :
Unknown CORBA exception id: 'IDL:omg.org/CORBA/INV_OBJREF:1.0'

(it may not be the exact message as i partialy translated it from my language)
The program still work when i'm running it as root.
I tried to copy /home/stab/evolution to /root/evolution to see if the program was
still running fine as root, and it was.
I also tried to reinstall evolution but nothing changed.

I am using evolution 1.4.6 with KDE 3.3 and Mandrake 10.0
As the error message mentioned gnome i wanted to try running evolution from gnome.
So i launched gnome (for the first time) and i had a bunch of error/warning messages.
Still, I managed to run evolution but had the same error message.

By the way, the error message doen't prevent evolution from loading but then the GUI
is quite messed up, and i can't do much things.

Does anyone have an idea to fix this ?
Thanks in advance

edit : can anyone tell me how to get rid of the smiley in the error message please ? :rolleyes:

stab 09-13-2004 06:01 AM

Now i remember that I updated my packages with rpmdrake.
I installed all updates in the bug updates / normal updates categories

Could this be the cause of my problem ?
Is there any way to uninstall the updates ?

thanks in advance for your help.

scuzzman 09-13-2004 06:10 AM

You'd have to uninstall the packages using rpmdrake, then reinstall from your CD's
I'm willing to bet certain Gnome libs got updated and others didnt, resulting in a backward compatibility issue

stab 09-13-2004 06:39 AM

do you have an idea of witch packages i should uninstall ?
shall i uninstall all those with "gnome" in the name ?

scuzzman 09-13-2004 06:42 AM

Uninstall Evolution and reinstall, see if that resolves the issue
If not, I'm not really sure but personally I'd reinstall Gnome

stab 09-13-2004 06:48 AM

i already tried uninstalling/reinstalling evolution but that changed nothing.

i will try to reinstall gnome as soon as i get home.

also, the strange thing is that evolution works perfectly if i run it as root.

stab 09-13-2004 02:52 PM

So i tried to uninstall gnome but after that i had very few application working,
and i couldn't load rpmdrake to reinstall it anymore.

So i formated the harddrive and reinstalled mandrake.
(That's what i usualy do when i can't overcome a problem :rolleyes: )

The problem is that even after that i got the same error with evolution.
This program was working fine when i first installed mandrake, so i guess
the reason why it won't work this time is that i may not have chosen the
exact same set of packages for this installation.

again, the program works fine when loaded as root.

any idea about how to fix this would be greatly appreciated,
thanks in advance.


All times are GMT -5. The time now is 07:34 PM.