LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   problem with starting Samba service (https://www.linuxquestions.org/questions/linux-newbie-8/problem-with-starting-samba-service-356351/)

honghebox 08-23-2005 10:26 PM

problem with starting Samba service
 
System: Fedora core 4
Tried to start the Samba server serveral times (tried from GUI: server settings -> services, and checked smb, then clicked start, also tried from terminal by typing service smb start). Error message says: "smb failed. The error was: Starting SMB services: [FAILED]

Starting NMB services: " Status is: "smbd is stopped
nmbd (pid 2528) is running..." .

Everytime when system boots up, Samba service also failed to start.

uninstalled and reinstalled Samba server, the problem still exists.

Please help me, thanks in advance!

flower.Hercules 08-23-2005 11:21 PM

# /etc/init.d/samba

That do anything?

honghebox 08-24-2005 04:14 PM

Quote:

Originally posted by flower.Hercules
# /etc/init.d/samba

That do anything?

Thanks for help, I tried exactly what your said and got the following error:
Starting SMB services: /etc/init.d/functions: line 83: 23749 Aborted $nice $*
[FAILED]
Starting NMB services:

quantum_leaf 09-01-2005 09:13 AM

looks like this is a known bug with SE linux

https://bugzilla.redhat.com/bugzilla....cgi?id=160582

schmee 09-23-2005 01:35 PM

(disclaimer) Below is a shotgun approach. See later posts for better solutions.

From `man samba_selinux` :
"You can disable SELinux protection for the samba daemon by executing:"
Code:

              setsebool -P smbd_disable_trans 1
              service smb restart

The above worked for me on FC4 (2.6.12-1.1447), with selinux-policy-targeted-1.25.4-10.1

James_Ecker 09-24-2005 11:29 AM

problem with starting Samba service
 
Check the context of secrets.tdb and smbpasswd they both need to be set to samba_secrets_t also check booleans.local file there should be a line that reads "samba_enable_home_dirs=1" without the quotes. This will allow SELinux to work proporly with Samba and visa-versa...

rafiqul 01-03-2006 11:20 PM

disabling SE_Linux at FC 4
 
I got the same error. here is what I did

at Desktop->System_Setting->Security Level disbaled the SELinux. And restarted the smb - it is working for me now.


All times are GMT -5. The time now is 04:55 PM.