LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-10-2014, 02:36 AM   #1
zak100
Member
 
Registered: Jul 2009
Posts: 225

Rep: Reputation: 2
problem with running httpd


Hi,
I am trying to run Apache server using

Code:
service httpd start
Its giving me following error:
Code:
      
Redirect to /bin/systemctl start
httpd.service

Failed to issue method call: Unit http.service is masked
Zulfi.
 
Old 11-10-2014, 12:09 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,260

Rep: Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437Reputation: 4437
Quote:
Originally Posted by zak100 View Post
Hi,
I am trying to run Apache server using
Code:
service httpd start
Its giving me following error:
Code:
Redirect to /bin/systemctl start
httpd.service

Failed to issue method call: Unit http.service is masked
Please see the Question Guidelines link in my posting signature, and the LQ Rules.

If you tried to put that error line into Google, you'd have found much. Since you don't tell us what version/distro of Linux you're using, version of Apache, or provide us any details at all, we can't help you. This could be related to iptables, or an unpatched version of Apache.
 
Old 11-10-2014, 12:59 PM   #3
Doug G
Member
 
Registered: Jul 2013
Posts: 749

Rep: Reputation: Disabled
man systemctl and review the information on mask and unmask. Apparently your httpd service is masked which prevents it from starting.
 
Old 11-11-2014, 02:48 AM   #4
zak100
Member
 
Registered: Jul 2009
Posts: 225

Original Poster
Rep: Reputation: 2
Hi,
Thanks for your information. I am using Fedora 20. I tried the following command:
Code:
systemctl unmask httpd
But its still giving the same error:

Code:
Failed to issue method call: Unit http.service is masked
I also tried "localhost" but its not showing the index page.

Please guide me.

Zulfi.
 
Old 11-11-2014, 07:43 PM   #5
Doug G
Member
 
Registered: Jul 2013
Posts: 749

Rep: Reputation: Disabled
I've never really used the mask/unmask systemctl commands. Perhaps there is some special action needed to unmask a service. You might want to find out how the httpd service got masked originally, if it's a company or school machine perhaps a system admin wants to prevent stray web servers on their network.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Running httpd problem after eprints installation vijaysince89 Linux - Server 2 11-02-2010 10:07 PM
httpd problem and caused my httpd to shut-down golpemortal Linux - Server 2 04-08-2007 04:44 AM
Apache problem: httpd (pid 2206?) not running newlinuxnewbie Linux - Software 2 09-05-2006 11:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration