-   Linux - Newbie (
-   -   problem with rpm command (

saipraveen 08-22-2005 05:15 AM

problem with rpm command
When i try to install anything using rpm -ivh i get the following error.

[root@localhost Linux_rpms]# rpm -ivh **************.rpm
dbiTagsInit: unrecognized tag name: "Sha1header" ignored
dbiTagsInit: unrecognized tag name: "Pubkeys" ignored
error: unrecognized db option: "tmpdir" ignored
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm

[root@localhost Linux_rpms]# rpm -qa mplayer
rpm: one type of query/verify may be performed at a time

Can anyone help me in this regard. Plz help me. I'm not able to install anything becoz of this

linmix 08-22-2005 05:32 AM

rpm -qa gives a list of all installed rpms. You should either do

#rpm -q mplayer (to see which mplayer is installed)
#rpm -qa | grep mplayer (to see all rpms with mplayer in their name installed)

as for the erros generated, was the rpm made for your distro?

saipraveen 08-22-2005 09:37 AM

I have already told that 'no rpm' is getting installed. Regarding rpm -qa , i tried
rpm -q mplayer and other things also. But it gives the same error.

linmix 08-22-2005 04:51 PM

The reason I asked if you were trying to install an rpm that was not made for your system/distro is because it might expect to find things that you don't have or look in the wrong places.

It looks like you may have a problem with your rpm database. Try rebuilding it with 'rpm --rebuilddb'

All times are GMT -5. The time now is 12:38 AM.